Post by mmc013 » Sat Feb 03, 2018 10:24 am

This internal server error is not documented in any of the logs.
During the upload process, the process fails, and a blank internal server error is announced twice in a white dialogue box. I didn't see any mention of this in the error logs.

This issue only happens when I'm uploading files to the live site. I don't have this issue when I'm uploading extensions to the localhost copy of this website.

What are some possibilities for this error or suggestions on how I might be able to fix it?

New member

Posts

Joined
Wed Jan 17, 2018 4:33 pm

Post by straightlight » Sat Feb 03, 2018 11:05 pm

Your host may require FTP to upload. There is an available extension on the marketplace that could probably help you with this. Although, without error / access logs posted, it would be harden to track the source of the issue.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by mmc013 » Sun Feb 04, 2018 7:56 am

The host looks like it may require ftp. So I'm probably just going to do that. Out of curiousity, if I were to manually upload all of the files to the same directories as listed in the compressed .ocmod folder, would it still work the same way as an installer?

New member

Posts

Joined
Wed Jan 17, 2018 4:33 pm

Post by mmc013 » Sun Feb 04, 2018 8:23 am

Oh also, for anyone else who may be experiencing this,

My specific issue was that I wasn't able to access the full error logs from opencart's dashboard. I checked the error logs from the ftp manager on my webhosting, and found that I was experiencing this error:

Class 'ZipArchive' not found in /home/'store'/public_html/admin/controller/marketplace/install.php on line 61

And that this is caused by not having zip archive manager installed on my hosting. (Godaddy)

If anyone else gets this, all you need to do is

Enter Godaddy dedicated server or webhosting > cpanel > php pear packages >
Find an extension 'zip'
search
Install
And if you had the same error as me you should be good uploading through the installer now.

New member

Posts

Joined
Wed Jan 17, 2018 4:33 pm

Post by straightlight » Mon Feb 05, 2018 12:00 am

Great instructions for webmasters using GoDaddy as a webhosting solution.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 4 guests