Post by alex_laseroffice » Wed Jan 31, 2018 8:25 pm

I need help :-)

I install OC 3.0.2.0 and personalize in Italian language. All OK.
Insert products and test order ... order email do not work
I test Mail and SMTP ... both do not work!
For test, I rename directory /system/library/mail in /system/library/mail.old and I reinserted an order and sent it again ... my surprise no error from OC and obviously no email received!!!
What am I doing wrong?

for your test my website: https://www.laseroffice.it/shop/

I test: https://www.laseroffice.it/shop/index.p ... on/contact
I receive email OK

thank you all for your help
Alex


Posts

Joined
Mon Feb 27, 2017 10:41 pm

Post by sarthakinfotech » Wed Jan 31, 2018 11:30 pm

hi,
you should use registered email id in cpanel.

Good Day,
Hiren
opencart blogs , opencart extensions/themes , custom development.


User avatar
New member

Posts

Joined
Tue Aug 05, 2014 1:12 am
Location - india

Post by alex_laseroffice » Thu Feb 01, 2018 12:01 am

Sorry, what is "registered email id" and where is "cpanel" ;D


Posts

Joined
Mon Feb 27, 2017 10:41 pm

Post by straightlight » Thu Feb 01, 2018 7:02 am

alex_laseroffice wrote:
Thu Feb 01, 2018 12:01 am
Sorry, what is "registered email id" and where is "cpanel" ;D
Look it up on Google / Youtube on how to use cPanel or similar host console. This is a must when saling products.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by alex_laseroffice » Thu Feb 01, 2018 6:39 pm

My hosting is dreamhost.com and they have a proprietary domain management panel, itsn't Cpanel

And I repeat ... the order e-mail does not go but the others, like that of the Contacts, go regularly.
Also, I have other websites on Dreamhost that use PHP and mail() and they work properly.


Posts

Joined
Mon Feb 27, 2017 10:41 pm

Post by straightlight » Fri Feb 02, 2018 6:49 am

It could be one to a million things. Without providing the access logs, a proper solution can't be posted.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by alex_laseroffice » Fri Feb 02, 2018 8:15 pm

In the logs no info ... log OC is empty, log Apache no info, mail log no info
What other log to watch?

As written above, OC when sending the order (I test this, rename /system/library/mail/ in /system/library/mail.old/) does not execute the files mail.php or smtp.php
While executing mail.php when sending the contact form (I test this, rename /system/library/mail/ in /system/library/mail.old/)

Tips?


Posts

Joined
Mon Feb 27, 2017 10:41 pm
Who is online

Users browsing this forum: No registered users and 3 guests