Post by jaychoo » Tue Nov 14, 2017 2:19 pm

Hi,

I would like to know if smoovpay payment gateway supports Opencart 3.0.2

Would appreciate if anyone share the integration.

Newbie

Posts

Joined
Wed Nov 08, 2017 5:27 pm

Post by straightlight » Tue Nov 14, 2017 9:29 pm

According to this page article: https://www.opencart.com/index.php?rout ... h=smoovpay , the latest version is: v2.3.0.2 . However, it can be easily converted to the latest version of Opencart.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by kestas » Tue Nov 14, 2017 9:53 pm

jaychoo wrote:
Tue Nov 14, 2017 2:19 pm
Hi,

I would like to know if smoovpay payment gateway supports Opencart 3.0.2

Would appreciate if anyone share the integration.
Hi,
You need ask developer of the extension for upgrading. Or make it by yourself.

Extensions you can find here


Active Member
Online

Posts

Joined
Tue Oct 12, 2010 2:23 am

Post by straightlight » Wed Nov 15, 2017 12:09 am

Updated for v3.x releases.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by jaychoo » Wed Nov 15, 2017 9:44 am

Hi straightlight,

thanks for the smoovpay plugins. I have just installed and awaiting my sandbox testing.

Newbie

Posts

Joined
Wed Nov 08, 2017 5:27 pm

Post by jaychoo » Wed Nov 15, 2017 11:51 pm

Hi,

Smoovpay was integrated and tested on sandbox.

When i do a test checkout, i will redirected to smoovpay to make payment. After payment was successful, i click a return page in the smoovpay to go back to success checkout page of my webpage.

Realised that the order become missing order. This only happen with cc payment.

Newbie

Posts

Joined
Wed Nov 08, 2017 5:27 pm

Post by jaychoo » Fri Nov 17, 2017 3:25 pm

Doesnt work. still appearing as missing order.

Newbie

Posts

Joined
Wed Nov 08, 2017 5:27 pm

Post by straightlight » Fri Nov 17, 2017 8:23 pm

Enable the debug mode in the admin payments module page for smoovpay and redo a transaction. Once the checkout process is done, check in your admin - > system - > maintenance - > error logs page for recent lines starting with:

Code: Select all

SMOOVPAY :: 

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by jaychoo » Mon Nov 20, 2017 9:36 am

there is no error on the smoovpay

Newbie

Posts

Joined
Wed Nov 08, 2017 5:27 pm

Post by straightlight » Mon Nov 20, 2017 9:41 am

Clear all caches from the Opencart admin and also your browser's cache. Close browser, reopen and try again with an order by leaving the debug mode on.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Mon Nov 20, 2017 10:35 am

I added some debug reports in the catalog/controller/extension/payment/smoovpay.php file. Replace the attached file and test an order again noticing if new logs will appear in the admin - > system - > maintenance - > error logs page beginning with: 'SMOOVPAY ::' .

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by jaychoo » Mon Nov 20, 2017 2:11 pm

clear cache in browser, systems/logs, and admin > maintenance > logs.

there is no error shown in the admin portal (admin > maintenance > logs.)

May I know where I can change the missing orders status to pending? so that missing orders will be pending

Newbie

Posts

Joined
Wed Nov 08, 2017 5:27 pm

Post by jaychoo » Mon Nov 20, 2017 3:21 pm

Seems that smoovpay extension is not updating the order status.

Newbie

Posts

Joined
Wed Nov 08, 2017 5:27 pm

Post by straightlight » Mon Nov 20, 2017 10:57 pm

Let's do some troubleshooting. In your admin/controller/extension/payment/smoovpay.php file,

find:

Code: Select all

$this->session->data['success'] = $this->language->get('text_success');
add above:

Code: Select all

echo "<pre />\n";
print_r($this->request->post);
echo "</pre>\n";

exit;
Then, resave changes in the admin-end for Smoovpay and submit the array that you see on screen (without API credentials).

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 8 guests