Post by matthewcoatney » Sat Sep 16, 2017 6:26 am

Working with OpenCart

In the Square Payment extension settings Square OAuth Redirect URL (which is greyed out/uneditable) is http:// not https://

When this is applied into Square's OAuth Redirect URL setting it is rejected because it is not https://

One thing that might be the problem is I get a Warning: SSL is not enabled on your admin panel. Please enable it to finish your configuration.
Even though I have enabled System->Settings->[store]->server->Use SSL option and changed http to https in both config.php But I can't figure this part out either.

Any suggestions?
Thanks in advance,


Wed Sep 13, 2017 7:31 am

Post by onefish » Fri Dec 22, 2017 1:04 pm

Matthew, did you ever get this figured out? I am just trying to get square setup on a new Opencart store and having the same issues. My hosting has ssl and I have activated ssl in Opencart with the tick box in System/Settings/Server. I haven't changed any code directly though. I am getting the same warning that you reported.

New member


Mon Nov 20, 2017 3:19 pm

Post by FCWC » Sun Jul 29, 2018 3:40 am

Not a good sign that I too have similar issue and its almost a year after the initial post.
Though mine does actually say https - they are greyed out and I can not copy and paste. Which means I can not get the complete CRON task info needed to finish setup.
I'm on A2Hosting. Used Softaculous auto installer. Maybe a rights issue?
If i figured it out I will come back and post solution.

New member


Tue Jul 31, 2012 3:17 am
Who is online

Users browsing this forum: TomWin and 13 guests