Post by dogart » Sat Sep 02, 2017 1:05 am

OK I'm pulling my hair out here!!!! O0
I am having issues with
OC Marketplace API - API Signature - API Signature hash does not match!

htaccess file - try to do SEO URL but when I turn it on I get 404 error on my pages
have tried various versions of htaccess files as suggested on this forum but nothing works.

I have default theme, have added a few basic free extensions.
Most extensions I try don't work!

Lack of help on the forum with trying to get some basic guidlines plus I don'y know
anything about coding! Twig yeah that's something from a tree right!!!! :laugh:

So is there a way to reinstall the basic guts of the OC v3.02 without losing all my work that
I have done so far to try and get things working again.

Should I just start all over again but go down to the latest version 2?

Any help REALLY APPRECIATED!

Newbie

Posts

Joined
Tue Aug 15, 2017 9:58 pm

Post by yodapt » Sat Sep 02, 2017 1:49 am

Maybe you are better off with 2.2.0.0, which is told to be the most stable OC release (not bug free though, smashing your hopes to the ground).

OC 3.x has a lot of unresolved issues yet, not as many extensions available, and .. that twig thing which is overkilling OC, in this developer's opinion ...

Opencart Developer - My Extension Showcase
Contact me at aeon.yoda@gmail.com


User avatar
Active Member
Online

Posts

Joined
Fri Jun 17, 2011 6:39 pm

Post by thinkingforward » Mon Sep 04, 2017 2:00 am

I'm having the same problem re signature hash. The button is currently red and does not accept the api from Opencart.

Let me know if you figure out a fix and I will do the same also!

Active Member

Posts

Joined
Wed Nov 25, 2009 2:55 am


Post by IP_CAM » Mon Sep 04, 2017 7:27 am

which is told to be the most stable OC release...

may be so, at least, when it comes to OC v.2 ! :laugh:
But better don't ignore, that STILL an even more proven stable Solution exists,
and without those OC Marketplace API - API Signature - big bulky Twig - and other
Secrets, just to have it mentioned too... ;)
Ernie

Ernie's OpenShop v.1.75 + OpenCart v.1.5.6.5 LIGHT Test Sites with free responsive Themes
http://www.bigmax.ch/shop/ - http://www.ebikes.li - http://www.ipc.li/shop/ - http://www.openshop.li/shop/
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by dogart » Mon Sep 04, 2017 9:33 am

So Ernie CH,

What do you say? Have any input to this maybe an answer to my issues that nobody seems to
have any suggestions for as I am about to delete the entire V3 OC and start again!!!!!!
Can't get SEO URL to work get 404's.
API signature doesn't get accepted.
Simple marketplace extensions haven't worked.

Newbie

Posts

Joined
Tue Aug 15, 2017 9:58 pm

Post by IP_CAM » Mon Sep 04, 2017 11:16 am

Well, if you have the Footer Signature Function active, you should be able to see
some Bottom-links, containing differently themed Test Shops. All based on the latest
OC v.1.5.6.5_rc Version, wich unfortunately 'collided' with the (some months earlier)
official release of the first OC Version 2. And so, 1.5.6.5 no longer was of any interest
for our beloved Master of the OC Universe. : :P - :choke:

And as a consequence of this, it suddenly faded away from the Github.com OC Version List,
at least visually, and there it is, since then, available only for those, smart enough, to still find it. >:D
https://github.com/opencart/opencart/tr ... 306fb75707
---
But, to get honest again, 1.5.6.5 is just the well-done OC v.1.5.6.4, with all errors and misses
fixed, still found during about 6 months after the formal 1.5.6.4 Release. And it also has NO
responsive Theme by Default, meaning, that some work is still waiting to be done, to make
this Version look and work just about like the latest Version 3, at least on the Front Side. ;)
---
Or then, one could download famous PEKU's OpenCart EDGE, it's already equipped with
1.5.6.5, with it's DEFAULT (OC v.2.0.3.1) Theme, and it even uses OcMod :D.
Like it's v.2/3 Brothers, if one cares, to use this kind of Extensions instead of VqMod.
STILL, it's not advised to use em BOTH. So, one should DISABLE OcMod, at best
BEFORE an Installation, because otherwise, it would be active, regardless of, if it's
equipped with QcMod's or not, and this would only uses ressources, for no good
reason at all.
download/file.php?id=29562
And, officially at least, no v.1.5.6 - OcMod's exist!
But since they can be adapted very easy, there is no good reason, not to use OcMod,
instead of VqMod, in an OpenCart v.1.5.6.5 ! ;) It makes one feel like riding on a v.3 :-*
http://dyisol.com/vqmod-to-ocmod-conversion-tool.php
Peku also offers the OC2-to-OC1.5 Theme Extension for free on the Extension Pages,
if one already runs a 1.5.6.x based Shop, and only plans to update the existing Theme,
just to mention this as well.
https://www.opencart.com/index.php?rout ... n_id=27779
https://www.opencart.com/index.php?rout ... n_id=23641
Some slight misses may still exist, they are hard to find, but then easy to fix. :D
---
Many other free and paid responsive Themes for OC 1.5.6.x also exist, a free and well-done
Bootstrap-3 Theme, shown on one of my Test Sites, is available in the Extension Section:
https://www.opencart.com/index.php?rout ... n_id=14631
And if one is willing to spend 20 Bucks, the nearby perfect Merkent Theme would be a great buy.
It's the most enhanced Piece of Code, by use of 'common master-files', to generate 'cat-type'
List/Grid Sections, and this much simplifies changes, then valid in all 'Sections', where Listings
exist. It's my personal Favoured Theme, I invested a few hundred hours already into it. One
disadvantage could be, that 'moduled' extensions partly need to be re-coded, to make use
of the custom Merkent 'common master-files' ways of doing it. And I would only be able to
eventually assist legally licensed users, just to mention this !
https://www.opencart.com/index.php?rout ... n_id=16822
---
When it comes to Extensions, existing in giant masses, those, 'interacting' with such Themes, by
displaying/changing Front Side Content, have usually to be rewritten a little, to still do their Job,
where and as they should. But this means, that someone has to have at least some basic
Coder Knowledge, and some spare time, to make a responsive Layout and OC 1.5.6.5-Setup
look and work at it's best, if one plans, to add some of the Mod's, built for this great Version.
---
Technically, OC v.1.5.6.5 is tested + works up to PHP 7.0.2x, but NOT PHP 7.1.x, for what reason
ever. This means, that one has to scrap it, in 10 Years or so, when PHP 7.0.x gets thrown
out of most Servers for good.
But by then, I bet, it won't be OC 3 anymore as well, giving you a hard time :laugh:
---
Conclusion:
Compared with later OC-Versions, for OC v.1.5.6.x , just about everything already exists, even
the Knowledge about it, on uncounted Sites worldwide. Therefore, it's more a decision, to always
jump onto the Band-Waggon, or then, rely on, what already has been proven reliable, for some time.
---
But this is only my very personal 'Feeling' on this, because I mainly decided to stay with this Version,
because it offers me the most free Code-Wisdom, for a colorblind Hobby-Coder like me, and I am
already quite familiar with it, after playing around with it for about 10K hours so far. :crazy: :crazy:
---
That's about it. And don't get me wrong, it's not my Baby, I just love it, because it was a FINAL
release. This keeps at least me from upgrading ever, and so starting new, every time again... :laugh:
Good Luck!
Ernie

PS: One more detail, an v.1.5.6.4/1.5.6.5 default Download CANNOT be installed
with PHP 7.0.x ! Only with an earlier PHP 5.x Version. But I mastered this Problem
already, if one needs the latest PHP-7.0.x OC v.1.5.6.5 Installation-Directory for it.
This Routine ALSO auto-creates OcMod Paths/Links in the config.php files,
and creates the Modification+Upload Subdirectories, just in CASE, that
someone ever decides on installing famous PEKU's OcMod-included V-2 to V-1.5.6
Theme-Extension ! :D
Otherwise, it will no do any harm, that those links+subs exist, but never will be used.
---
Just keep it secret, please, I don't want to wake up the Boss... ! 8)

Attachments

OC v.1.5.6.4/1.5.6.5 installation Package for up to PHP v.7.0.2x / MySqli


Ernie's OpenShop v.1.75 + OpenCart v.1.5.6.5 LIGHT Test Sites with free responsive Themes
http://www.bigmax.ch/shop/ - http://www.ebikes.li - http://www.ipc.li/shop/ - http://www.openshop.li/shop/
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland
Who is online

Users browsing this forum: No registered users and 2 guests