Post by dupfold » Thu Aug 17, 2017 11:20 pm

Hello

I've update from 2.3.0.2 to 3.0.2.0, but website now states 'Error: A theme has not been assigned to this store!'. Whilst then trying to fix that, I get "Permission Denied! - You do not have permission to access this page, please refer to your system administrator.". I no longer have access to any settings via dashboard. The only things on navigation bar is 'Dashboard', 'Catalog' and 'Reports'.

1. How do I fix this so as I have permission again? I am/was the only administrator.

2. How do I fix theme error?

Thank you
Last edited by dupfold on Fri Aug 18, 2017 9:29 pm, edited 1 time in total.

New member

Posts

Joined
Wed Oct 21, 2015 3:42 am

Post by pm-netti » Fri Aug 18, 2017 4:22 am

This is 2 lines Sql ( change/add DB_PREFIX, is need)

Code: Select all

UPDATE extension SET `code` = 'default' WHERE `type` = 'theme';
UPDATE setting SET `value` = 'default' WHERE `key` = 'config_theme';
Add this your in phpmyadmin page.

Ps. Your need go to admin > user > user group and add full permissions. Oc 3.x use new route marketplace/extension

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by dupfold » Fri Aug 18, 2017 9:30 pm

Thanks pm-netti, but where do I find 'phpmyadmin' page please?

Also as said, I no longer have access to admin > user > user group. The only things I have visible now on dashboard are Catalog and Reports. How can I gain full permission again please without the use of the dashboard?

New member

Posts

Joined
Wed Oct 21, 2015 3:42 am

Post by pm-netti » Fri Aug 18, 2017 10:36 pm

dupfold wrote:
Fri Aug 18, 2017 9:30 pm
Thanks pm-netti, but where do I find 'phpmyadmin' page please?

Also as said, I no longer have access to admin > user > user group. The only things I have visible now on dashboard are Catalog and Reports. How can I gain full permission again please without the use of the dashboard?
Is you cpanel ? It url can be yourstore.com:2083 or yourstore.com/cpanel, phpmyadmin found there. You can ask it your Host.
Was your store 2.3.0.2 upgraded version or clean installation? If it is upgrade, your maybe need change column 'permission' type to 'mediumtext' to table 'user_group'.

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by dupfold » Fri Aug 18, 2017 11:38 pm

Thanks... but I gave up and just done clean install of 3.0.2.0. ;D

New member

Posts

Joined
Wed Oct 21, 2015 3:42 am
Who is online

Users browsing this forum: No registered users and 3 guests