Post by Sinsecato » Mon Aug 07, 2017 11:26 pm

I am having some issues with SSL and my multistore setup.

Primary store is at http://example.com/PrimaryStore/
Secondary Store is at http://SecondaryStore/example.com/

I have turned on 'use SSL' in Settings -> Server, and edited both config files. I can access the Primary Store and Admin in both http and https. I can access the Secondary Store in http. But when I attempt to access the Secondary Store with https it loads my home directory rather than the Secondary Store. So for some reason the http version of the subdomain is redirecting to the main store directory properly, but the https version is simply reading the subdomain folder as empty.

I do have a Wildcard SSL certificate.

I was able to find this forum post with a somewhat similar issue:

http://code.mytodayaz.com/opencart/-sol ... 64842.html

relevant excerpt:

"index.html is working on non-SSL but not on your SSL - I just tried using the domain you left in your config dump

Looks like a server problem to me, this is only a guess, but in your domain root you have httpdocs and httpsdocs ?

Looks like some sort of config option needs to be set in your server control panel to force https (SSL) to read not only from httpsdocs but also from httpdocs

I know there is a similar option in Plesk control panel to do this, maybe there is a similar option in your control panel if not using Plesk"

-------

I contacted my hosting company, bluehost, and was told that it's not a server side issue.

Any help is appreciated
Last edited by Sinsecato on Sat Sep 09, 2017 12:25 am, edited 1 time in total.

Newbie

Posts

Joined
Mon Aug 07, 2017 11:08 pm

Post by labeshops » Tue Aug 08, 2017 8:03 pm

I believe you have to use the same url conventions if you use subdomains on opencart. Not something I've done myself, but I seem to remember this mentioned somewhere.

So

Primary store is at http://example.com/PrimaryStore/
Secondary Store is at http://SecondaryStore/example.com/

Needs to be

Primary store is at http://example.com/PrimaryStore/
Secondary Store is at http://example.com/SecondaryStore/

Running Opencart v2.2 with multi-stores from http://www.labeshops.com which has links to all my stores.

Image


User avatar
Expert Member

Posts

Joined
Thu Aug 04, 2011 4:41 am
Location - Florida, USA

Post by Sinsecato » Sat Sep 09, 2017 12:19 am

It turned out to be a problem with my hosting service (bluehost) being unable to install the wildcard SSL certificate correctly. I have now switched hosting and gotten the problem resolved. Namely the wildcard SSL must be installed separately for each subdomain.

Newbie

Posts

Joined
Mon Aug 07, 2017 11:08 pm
Who is online

Users browsing this forum: lgcouturier and 7 guests