Post by lastbadguy » Sat Feb 10, 2018 9:41 am

getting the following error message when installing

Warning: mysqli::mysqli(): (HY000/2002): No such file or directory in /hermes/walnaweb12a/b429/as.deviouspleasure/system/library/db/mysqli.php on line 7Warning: DB\MySQLi::__construct(): Couldn't fetch mysqli in /hermes/walnaweb12a/b429/as.deviouspleasure/system/library/db/mysqli.php on line 10Warning: DB\MySQLi::__construct(): Couldn't fetch mysqli in /hermes/walnaweb12a/b429/as.deviouspleasure/system/library/db/mysqli.php on line 10Notice: Undefined variable: mysql in /hermes/walnaweb12a/b429/as.deviouspleasure/install/controller/install/step_3.php on line 280Notice: Trying to get property of non-object in /hermes/walnaweb12a/b429/as.deviouspleasure/install/controller/install/step_3.php on line 280


any insight would be greatly appreciated.

Newbie

Posts

Joined
Sat Feb 10, 2018 2:56 am

Post by straightlight » Sun Feb 11, 2018 1:55 am

Do not use FTP to manually upload these files with a queue one-by-one. Rather upload the Opencart ZIP file on your host file manager console. Then, use the extract function. This is way more efficient and these files are being extracted within a few seconds rather than waiting 45 minutes on a decent server for all those files to be uploaded. On the plus side, all the files will be uploaded successfully since they will be extracted on the server directly.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by lastbadguy » Wed Feb 14, 2018 12:43 am

thank you for your response. I have taken your advice, unfortunately that hasn't resolved my issue. additionally i am getting the following error if i go directly to the domain

"Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log."

any other ideas?

Newbie

Posts

Joined
Sat Feb 10, 2018 2:56 am

Post by straightlight » Wed Feb 14, 2018 6:41 am

Ensure to follow the install.txt file provided from the downloaded Opencart ZIP file from opencart.com regarding folder permissions that needs to be recursively set.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by lastbadguy » Thu Feb 15, 2018 7:51 pm

I went back and double checked to make sure all permissions were set correctly. still have the same error

Newbie

Posts

Joined
Sat Feb 10, 2018 2:56 am

Post by straightlight » Fri Feb 16, 2018 5:56 am

Ensure to have properly configured your server paths in your config.php and admin/config.php files.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by lastbadguy » Sat Feb 17, 2018 12:44 am

straightlight wrote:
Fri Feb 16, 2018 5:56 am
Ensure to have properly configured your server paths in your config.php and admin/config.php files.
both of those files are completely empty. the installation has never completed on the live server to fill them in

Newbie

Posts

Joined
Sat Feb 10, 2018 2:56 am

Post by lastbadguy » Sat Feb 17, 2018 1:16 am

I have found my issue. where the setup called for a hostname I had localhost. my installation uses a different value than localhost.

I've managed to complete the installation but when i try and visit the domain directly I still get the internal error 500


Straightlight I appreciate your responses and attempts to guide me through my ignorance.

Newbie

Posts

Joined
Sat Feb 10, 2018 2:56 am

Post by straightlight » Sat Feb 17, 2018 6:44 am

I've managed to complete the installation but when i try and visit the domain directly I still get the internal error 500
Look at your webserver access logs from your root FTP access - > access_logs or logs or from your host console - > error logs icon regarding the most recent index: 500 .

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by lastbadguy » Thu Mar 08, 2018 2:16 am

straightlight wrote:
Sat Feb 17, 2018 6:44 am
I've managed to complete the installation but when i try and visit the domain directly I still get the internal error 500
Look at your webserver access logs from your root FTP access - > access_logs or logs or from your host console - > error logs icon regarding the most recent index: 500 .
only access_log i can find contains info like this:

52.165.148.51 - - [06/Mar/2018:00:55:26 -0500] "GET / HTTP/1.1" 500 519 "-" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.94 Safari/537.36"


not exactly helpful. any other suggestions?

Newbie

Posts

Joined
Sat Feb 10, 2018 2:56 am

Post by oLDu67 » Sat Sep 15, 2018 11:32 pm

i solved this problem. i edited to corret "username".

Newbie

Posts

Joined
Sat Sep 15, 2018 11:27 pm
Who is online

Users browsing this forum: No registered users and 10 guests