Post by mauprik » Wed Jun 06, 2018 11:29 pm

I'm trying to import product data from a .xlsx file into OC v 3.0.2.0, which is installed on my webhosting server. I've first exported 1 product to see how the columns in the xlsx file are ordered. I've exported my product data from my old webshop tot a .csv file and copied this data into a new tab in my .xlsx file.
With several excel functions I've places all the data in the right columns and copied the functions to data only.
When importing the .xlsx file to OC I get the following massage:

Error: You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ''1087',,'',1,37.5,0,NOW(),NOW(),NOW(),1150,7,1,0,0,0,0,0,'4','0','1','1')' at line 1
Error No: 1064
INSERT INTO `oc_product` (`product_id`,`quantity`,`sku`,`upc`,`ean`,`jan`,`isbn`,`mpn`,`location`,`stock_status_id`,`model`,`manufacturer_id`,`image`,`shipping`,`price`,`points`,`date_added`,`date_modified`,`date_available`,`weight`,`weight_class_id`,`status`,`tax_class_id`,`viewed`,`length`,`width`,`height`,`length_class_id`,`sort_order`,`subtract`,`minimum`) VALUES (50,1,'','','','','','','',,'1087',,'',1,37.5,0,NOW(),NOW(),NOW(),1150,7,1,0,0,0,0,0,'4','0','1','1');

OC is installed with a MySql database, not a MariaDB. Can anybody here tell me what I did wrong and how I can fix this problem? I.ve searched this forum and found previous items with the same error, but there was no good answer till now, at least I couldn't find it...

Please need some help in this as a newby with OC.

Newbie

Posts

Joined
Sun Dec 03, 2017 10:54 pm
Location - The Hague, Netherlands

Post by mauprik » Fri Jun 08, 2018 3:55 pm

After another search in the forum, I stumbled upon an answer, which gave me insight in how to read the error message and therefore solve my problem. In my import file there was data missing on places which are commendatory. I've looked in the database, which fields must contain data and filled this in, in my import file. After that the import went without error's.

Sorry for placing an unnecessary question.

Greetings,
Rik.

Newbie

Posts

Joined
Sun Dec 03, 2017 10:54 pm
Location - The Hague, Netherlands
Who is online

Users browsing this forum: No registered users and 5 guests