Post by frankpmjr » Mon May 07, 2018 8:37 am

Hi,
I am new to Open Cart and attempting to create a new instance of Open Cart for a client. I can't seem to upload the products (over 1900) into the site. I keep getting the following error:
The Twig_Autoloader class is deprecated since version 1.21 and will be removed in 2.0. Use Composer instead.

There is more to it but its mostly calling what file the file is causing the error (this is an example: system/library/template/Twig/Autoloader.php). Anyway, I installed Composer but I probably need to reference it in the
system/library/template/Twig/Autoloader.php file and I have no idea how to update the method to do that.

Can I get a bit of guidance? Thanks

Newbie

Posts

Joined
Sun Jan 21, 2018 2:03 am

Post by frankpmjr » Mon May 07, 2018 11:05 am

OK I'm not sure what exactly I did to fix the issue but here is the order of events.
I installed Composer on my Server
I Installed the Template switcher from the same developer in Open Cart as a module
I corrected some issues with the CSV I was uploading that hold the products.
I think maybe the error I put up earlier is a general error thrown when there is an issue with the feed. I'm not positive since I didn't test in between each activity.

Newbie

Posts

Joined
Sun Jan 21, 2018 2:03 am

Post by mobimain » Wed Jul 11, 2018 7:02 pm

frankpmjr wrote:
Mon May 07, 2018 11:05 am
OK I'm not sure what exactly I did to fix the issue but here is the order of events.
I installed Composer on my Server
I Installed the Template switcher from the same developer in Open Cart as a module
I corrected some issues with the CSV I was uploading that hold the products.
I think maybe the error I put up earlier is a general error thrown when there is an issue with the feed. I'm not positive since I didn't test in between each activity.

tell me how you installed the composter under the opencart. I have the same problem

Newbie

Posts

Joined
Tue Jul 03, 2018 9:00 pm
Who is online

Users browsing this forum: No registered users and 8 guests