Post by suzukishoes » Sun Feb 25, 2018 6:20 am

I’ve installed advanced booking and reservation but I’m returning the “ Warning: You do not have permission to access the API!”

I’ve tried all the usual system changes with no luck. I read somewhere this could be to do with https and I run on http as I don’t have a security certificate on my server. Is there anything I can change to get round this?
I’ve looked on the market place and can’t find a disable API for version 3

I’m at my googling wits end! Any help ?

Lee

New member

Posts

Joined
Tue May 01, 2012 4:45 pm

Post by straightlight » Sun Feb 25, 2018 6:23 am

This extension may be useful: https://www.opencart.com/index.php?rout ... n_id=30437 . While this seem to be compatible with the v2.x releases of OC, you can use the Template Switcher extension for compatibility.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by suzukishoes » Sun Feb 25, 2018 6:28 am

Thank you can you explain to me the template switcher?

New member

Posts

Joined
Tue May 01, 2012 4:45 pm

Post by straightlight » Sun Feb 25, 2018 6:33 am

Followed are the full details about the Template Switcher extension: https://www.opencart.com/index.php?rout ... n_id=31589

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by suzukishoes » Sun Feb 25, 2018 6:47 am

Thanks for that. Do you think http / https is likely to be the cause of the error in the first place? (Just trying to improve my understanding)

New member

Posts

Joined
Tue May 01, 2012 4:45 pm

Post by straightlight » Sun Feb 25, 2018 6:58 am

One way to find out is by disabling the API. Try before you buy.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by suzukishoes » Mon Feb 26, 2018 9:15 pm

I've installed the template switcher which was easy & straightforward but there are no install instructions on the disabling api checks. As this is for an older version I'm not sure what to do with it.
Where do I put the disable_api_checks.ocmod.xml file & how do I get it to do its stuff?

Regards

Lee

New member

Posts

Joined
Tue May 01, 2012 4:45 pm

Post by suzukishoes » Mon Feb 26, 2018 9:28 pm

I've also just installed Integrated VQmod for OpenCart but still unsure how to get the file loaded (where) & how to get it running

New member

Posts

Joined
Tue May 01, 2012 4:45 pm

Post by suzukishoes » Mon Feb 26, 2018 11:28 pm

I'm sorted now but for future reference to those trying to get round the api thing in version 3.0.3.0 install both items as suggested but do this to the disable_api_checks.ocmod.xml file.

1)change your xxx.xml file name to install.xml

2)archive the file as xxx.ocmod.zip.

3)go to extension->installer ,and upload it.

New member

Posts

Joined
Tue May 01, 2012 4:45 pm
Who is online

Users browsing this forum: DigitCart, wasikovee and 10 guests