Post by mmc013 » Wed Feb 14, 2018 5:12 am

Opencart v3.0.2.0
Extension: Popup Box Module Pro 2.2.0

Installed module through oc installer, added and enabled the extension, configured the module to display on the front page. After saving and loading the front page I encountered this error code. Is there something that I'm missing?

New member

Posts

Joined
Wed Jan 17, 2018 4:33 pm

Post by mmc013 » Wed Feb 14, 2018 6:37 am

Additional Detail:
The following is the popup_box_base.php file that is being referenced by the fatal error.

Code: Select all

    // When the specified template file is not found, OpenCart 3 shows a blank page instead of throwing a fatal error, so we do it manually.
    if (version_compare(VERSION, '3.0.0.0', '>=')) { // OpenCart 3.0.0.0 or later.
      if (!is_file(DIR_TEMPLATE . $this->config_template . '/template/' . $template . '.twig')) {
        trigger_error('The specified template file is not found: ' . htmlentities($template), E_USER_ERROR);
        return;
      }
    }
    
    return $this->load->view($template, $data);  
  }
  
  /**
   * Get parameters from key:value string data where each element is separated by line feed.
   *
   * @param   string  $params
   * @return  array   A set of parameters
   */   
I'll respond back if I figure it out before a different user is able to explain it

New member

Posts

Joined
Wed Jan 17, 2018 4:33 pm

Post by straightlight » Wed Feb 14, 2018 7:28 am

Contact the extension developer to resolve this issue.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 3 guests