Post by straightlight » Sat Jan 20, 2018 6:04 am

If you don't see the results, it means the transaction may simply not be able to reach the callback() method from your Authorize.net (SIM) payment module. Ensure your callback URL is properly configured from your Authorize.net account

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by StormDesigner » Fri Jan 26, 2018 3:29 am

Hey, still on this. So this is interesting. I was logged into authorize.net and saw that the "Relay Response URL" didn't match what was in the cart. copied the URL from my opencart to Authorize.net (admin). Attempting a transaction never came back to the cart. Instead, the page that drew at

Code: Select all

https://secure.authorize.net/gateway/transact.dll
contained this unformatted response.

Notice: Undefined index: x_login in /home/myUID/public_html/mydomain.com/shop/catalog/controller/extension/payment/authorizenet_sim.php on line 51Warning: Cannot modify header information - headers already sent by (output started at /home/myUID/public_html/mydomain.com/shop/catalog/controller/startup/error.php:34) in /home/myUID/public_html/mydomain.com/shop/system/library/response.php on line 36

There are also two errors in the error log matching that statement.

I then thought, well maybe if I change the "Relay Response URL" in my opencart admin to match the default from Authorize.net, but apparently that can't be modifed?, at least not from my opencart admin. Which strikes me as odd as it is located in a "text-area" for "input-callback" but text in the cell can't be modified. The text area code notes: readonly=""

The Relay Response URL default from authorize.net (the one which returns shoppers to the cart but doesn't update the order status to "Processing" or "Empty Shopping Cart Contents" is:

Code: Select all

https://www.mydomain.com/shop/index.php?route=checkout/success
- the one stuck in the module's admin is

Code: Select all

https://www.mydomain.com/shop/index.php?route=extension/payment/authorizenet_sim/callback
- what the heck already!? I expected Authorize.net to be able to advise on this but they could not though I will begin a comment on their developer forums as well. Any idea where "Relay Response URL" is set or if that can be modified? I did a search for it in the sim module but that address didn't seem to be present.
.

StormDesigns, Inc. Website Design and Web Application Development - plus graphic design and print media.

www.StormDesigns.com


User avatar
New member

Posts

Joined
Wed Feb 01, 2012 1:53 am


Post by KenHorse » Sun Apr 15, 2018 3:46 am

Did you ever resolve this? I am facing a similar situation where I've changed carts (finally left MijoSoft and their horrible "service" and I'm now working on getting JooCart going) but all my CC transactions result in a "Failed Payment" return and the template formatting for that page is all messed up too.

No entries in the error log either

New member

Posts

Joined
Fri Nov 23, 2012 1:39 am

Post by straightlight » Sun Apr 15, 2018 5:39 am

As I predicted from my previous reply, it is a configuration issue stuck in the callback() method. Follow these instructions for the Relay Response URL settings: https://account.authorize.net/help/Acco ... sponse.htm .

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 12 guests