Post by fl3tch3r85 » Mon Nov 20, 2017 10:52 pm

Can anyone help me with this problem please, I have tried editing the category.twig with no avail.
Many thanks

Image

Newbie

Posts

Joined
Sat Nov 18, 2017 8:08 pm

Post by straightlight » Tue Nov 21, 2017 2:39 am

What is the OC version?

Revert to the default theme and see if this issue can be replicated.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by fl3tch3r85 » Thu Nov 23, 2017 4:23 am

After having a play around, its got to be a coding error due to it only happening when there are 6 or more categories. Prior to 6, there is just one column of listed categories. Once there are 6 categories, the other columns fill up with duplicates.

Where would the file be to edit this?

Newbie

Posts

Joined
Sat Nov 18, 2017 8:08 pm

Post by straightlight » Thu Nov 23, 2017 4:25 am

Although, your theory is based on the custom theme's screenshot you posted above. As suggested, switch to the default theme and see if this issue can be replicated.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by fl3tch3r85 » Thu Nov 23, 2017 4:56 am

Yes exactly the same when reverting back....

Image

Newbie

Posts

Joined
Sat Nov 18, 2017 8:08 pm

Post by straightlight » Thu Nov 23, 2017 5:09 am

In catalog/view/theme/<your_theme>/template/product/category.twig file,

find:

Code: Select all

{% if categories|length <= 5 %}
The default value is set to smaller or equal to 5.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by fl3tch3r85 » Thu Nov 23, 2017 5:36 am

That all seems correct, thanks for suggestion really appreciate. I am finding that no matter what i change in the .Twig file doesnt make any difference what so ever, making me think im editing the wrong file. I have cleared cache etc, this is the last problem to solve before my site is complete so I am pulling my hair out lol.

Newbie

Posts

Joined
Sat Nov 18, 2017 8:08 pm

Post by straightlight » Thu Nov 23, 2017 5:54 am

If you cleared all your cache for Opencart and the browser's, ensure your system/storage folder is writable on your file server.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by fl3tch3r85 » Thu Nov 23, 2017 6:18 am

It is set to writable only on the "Owner Permission" section, is this correct?

Newbie

Posts

Joined
Sat Nov 18, 2017 8:08 pm

Post by straightlight » Thu Nov 23, 2017 6:24 am

Set permissions recursively to the storage folder with CHMOD 0755.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by fl3tch3r85 » Thu Nov 23, 2017 6:28 pm

No luck, still the same. I have even tried removing the Category.twig from the FTP thinking there would be a noticable change on the front end, but nothing what so ever.

I am currently editing files at the location "/catalog/view/theme/tt_nego1/template/product/Category.twig"

Maybe I should be editing in another location?

Surely im missing something :(

Newbie

Posts

Joined
Sat Nov 18, 2017 8:08 pm

Post by fl3tch3r85 » Thu Nov 23, 2017 8:22 pm

Right, I am finally getting somewhere. It looks like the problem is down to an extension "OC Layered Navigation Ajax" As soon as I have disabled this, the refine search is working how I wanted, although there is a slight difference in look, I am happy its working as it should. Just going to add more categories etc to test fully.

Many thanks for all your help

Newbie

Posts

Joined
Sat Nov 18, 2017 8:08 pm
Who is online

Users browsing this forum: rugged24 and 11 guests