Post by imakeitwork » Tue Aug 08, 2017 7:46 pm

I'm building an extension for OpenCart v3.xxx . It does install and work as it should, but it shows disabled status when I check the extension list. Any tips how it's controlled?

Image

Thanks!

ImakeITwork.net - OpenCart extensions that save time and simplify administration
Image Image


New member

Posts

Joined
Mon May 05, 2014 5:07 pm


Post by swguy » Sat Aug 12, 2017 8:46 pm

When you install a module, its initial status is disabled. Click the pencil icon and update the status to enabled.

Better Together: Buy one product, get another at a discount.
Discount Chooser: Buy a group of products, get another group at a discount.


User avatar
New member

Posts

Joined
Mon Apr 15, 2013 4:13 am

Post by linetrace » Thu Aug 17, 2017 7:17 am

Did you get your extension to enable? I ran into an issue when porting a theme from 2.3.x to 3.0.2.0 that the status setting (and maybe others) seemingly needed to have a "theme_" prefix for enabling/disabling to actually work (the non-prefixed setting saved & loaded, but wasn't recognized as actually enabled). Anyone know if that is something new with 3.0.x that might apply to other extension types as well?

Newbie

Posts

Joined
Sat Aug 05, 2017 4:42 am
Location - Winooski, VT, US

Post by annaraiders » Wed Aug 23, 2017 2:16 pm

opencart 3 uses prefix for module, theme, shipping etc . For module it should start with module_ for theme theme_ .
For enable status you should have module_extensionname_status in your extension module - if you change enable or disable the status it will be changed.

LATEST THEMES - Opencart Themes and Custom theme development
LT WEB HOST - Domain and Hosting


Newbie

Posts

Joined
Tue Jan 08, 2013 2:30 pm
Location - INDIA
Who is online

Users browsing this forum: No registered users and 5 guests