Post by giancarlo64 » Fri Sep 14, 2018 9:37 pm

I to all,
I have moved my Opencart from an internal server (debian 8 32 bit) to another server (Debian 9 64bit, PHP7) and I get the following error:

VQMod::bootup - ERROR - YOU NEED THE PHP "DOMDocument" EXTENSION INSTALLED TO USE VQMod

Verified with phpinfo()

dom
DOM/XML enabled
DOM/XML API Version 20031129
libxml Version 2.9.4
HTML Support enabled
XPath Support enabled
XPointer Support enabled
Schema Support enabled
RelaxNG Support enabled

Running the installation of VQmod give me

VQMOD ALREADY INSTALLED!

What could it be?

Regards

Gian Carlo

New member

Posts

Joined
Tue Jun 27, 2017 6:30 pm

Post by straightlight » Fri Sep 14, 2018 10:32 pm

VQMod::bootup - ERROR - YOU NEED THE PHP "DOMDocument" EXTENSION INSTALLED TO USE VQMod
Server specs specified, no OC version provided. Contact your host to install the DOMDocument server library.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by giancarlo64 » Fri Sep 14, 2018 11:47 pm

Hi straightlight,
OC version is 3.0.2.0

In the meantime I have found the problem:

In debian 9 the the site directory is no more var/www/mysite but www/html/mysite

I have changed all the reference including the "html" in config.php and admin/config.php
I also changed the IP to the new one

And at the end I uploaded the exported DB that I didn't upload before.

Now the site is working ok. Strange because I didn't get a DB error on the HTML page.

Gian Carlo

New member

Posts

Joined
Tue Jun 27, 2017 6:30 pm
Who is online

Users browsing this forum: No registered users and 3 guests