Post by shashibp » Sat Sep 15, 2018 7:06 pm

Dear Opencart Team ,

Our Website is in opencart VERSION:2.1.0.2

On Checkout page when we click Confirm order - we get the order confirmation mail etc. But the page does not redirect to the Thank you page . It only redirects once we click the confirm order button again.

So the confirm order button needs to be clicked twice. That is not how it should be obviously, it should go to the thank you page in 1 click.

we have shipping method and payment method - ON
we are using flat shipping method
and payment method we where using paypal payflow pro - but as the issue was misunderstood - and no support from paypal team hence we shifted to Authorizenet Aim today and found same issue here too

but if we confirm order in Free Checkout - then its work well
then why issue is in payment methods

please help me out ..as its has taken more then month...and if no solution - then i might loss my client too ...as he is very upset on this case

hoping for best

Newbie

Posts

Joined
Sat Jul 08, 2017 6:07 pm

Post by straightlight » Sat Sep 15, 2018 7:33 pm

please help me out ..as its has taken more then month...and if no solution - then i might loss my client too ...as he is very upset on this case
What might even be more upsetting is the following: OP posted in bug reports. No error / server access logs provided with claim regarding double-click event without redirection. Forum rules unfollowed.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by khnaz35 » Sat Sep 15, 2018 7:45 pm

straightlight wrote:
Sat Sep 15, 2018 7:33 pm
please help me out ..as its has taken more then month...and if no solution - then i might loss my client too ...as he is very upset on this case
What might even be more upsetting is the following: OP posted in bug reports. No error / server access logs provided with claim regarding double-click event without redirection. Forum rules unfollowed.
Here come help with attitude

Always help others it's always come back, give and receive :)


User avatar
Active Member

Posts

Joined
Mon Aug 27, 2018 11:30 pm

Post by shashibp » Mon Sep 17, 2018 2:23 pm

Haha,

There is no error message display on screen ...

on first click - confirm order button text change to " loading.... " and in few sec its back to confirm order text..and we have received order mail ..but it not redirect to thank you page .. now when we click again confirm order button then its take us to thank you page .. but no order mail this time..

also as said ... confirm order button works well in Free Checkout process ..thats o first click its redirect to thanks you page ...
its issue only when i active any payment gateway

will try to post my error log for same...

update below is my errorlog :

error log :

Code: Select all

2018-09-17 6:33:37 - PHP Notice:  Undefined variable: empid_number in public_html/website/catalog/model/checkout/order.php on line 804
will try to define same and will check ..if still any issue ... but i doubt ..bcz same is working well with free checkout ...then why only issue with payment gateway ....
thanks

Newbie

Posts

Joined
Sat Jul 08, 2017 6:07 pm

Post by OSWorX » Mon Sep 17, 2018 4:21 pm

It seems that you have installed additional extensions, one reason (and I am sure the one why it does not work) for your troubles.
The Free checkout method works in a another way as all others.

Fix that error you have posted, and it should work.

Forum Rules: viewtopic.php?f=176&t=200480
Commercial Request: viewforum.php?f=88

Image


User avatar
Expert Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by straightlight » Mon Sep 17, 2018 9:03 pm

Contact the extension developer to resolved this issue. Not an OC bug, posted in wrong section.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by khnaz35 » Tue Sep 18, 2018 4:42 pm

straightlight wrote:
Mon Sep 17, 2018 9:03 pm
Contact the extension developer to resolved this issue. Not an OC bug, posted in wrong section.
Why not to help people if you understand the problem, instead of pushing them to extension dev, if they are open topic or thread it could be mean that they don't have support any more OR they want to learn also

Always help others it's always come back, give and receive :)


User avatar
Active Member

Posts

Joined
Mon Aug 27, 2018 11:30 pm

Post by straightlight » Tue Sep 18, 2018 5:59 pm

khnaz35 wrote:
Tue Sep 18, 2018 4:42 pm
straightlight wrote:
Mon Sep 17, 2018 9:03 pm
Contact the extension developer to resolved this issue. Not an OC bug, posted in wrong section.
Why not to help people if you understand the problem, instead of pushing them to extension dev, if they are open topic or thread it could be mean that they don't have support any more OR they want to learn also
If they don't have support for it and requires support for them, they can either contact the extension developer, site support or to create a new service request in the Commercial Support section of the forum. Forum rules.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by khnaz35 » Tue Sep 18, 2018 6:14 pm

straightlight wrote:
Tue Sep 18, 2018 5:59 pm
khnaz35 wrote:
Tue Sep 18, 2018 4:42 pm
straightlight wrote:
Mon Sep 17, 2018 9:03 pm
Contact the extension developer to resolved this issue. Not an OC bug, posted in wrong section.
Why not to help people if you understand the problem, instead of pushing them to extension dev, if they are open topic or thread it could be mean that they don't have support any more OR they want to learn also
If they don't have support for it and requires support for them, they can either contact the extension developer, site support or to create a new service request in the Commercial Support section of the forum. Forum rules.
how about their learning process ?

Always help others it's always come back, give and receive :)


User avatar
Active Member

Posts

Joined
Mon Aug 27, 2018 11:30 pm

Post by straightlight » Wed Sep 19, 2018 5:37 am

The learning process goes with the knowledge users can gain by using the already developed 24/7 tool called: Google for something they mostly may look for an answer for free as well as reading the forum rules before creating a new topic. So far, the OP user posted in the wrong section of the forum since a Bug Report claim needs to be reproduced by others by posting facts. In this case, only theory explanations / past history has been posted.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by khnaz35 » Wed Sep 19, 2018 10:47 am

straightlight wrote:
Wed Sep 19, 2018 5:37 am
The learning process goes with the knowledge users can gain by using the already developed 24/7 tool called: Google for something they mostly may look for an answer for free as well as reading the forum rules before creating a new topic. So far, the OP user posted in the wrong section of the forum since a Bug Report claim needs to be reproduced by others by posting facts. In this case, only theory explanations / past history has been posted.
I am agree with you on few things but not at all. The forum section here in opencart is so complicated. That's why its a common mistake to post in other forum. :-[
well i would say its all about learning and implementation 8)

Always help others it's always come back, give and receive :)


User avatar
Active Member

Posts

Joined
Mon Aug 27, 2018 11:30 pm
Who is online

Users browsing this forum: No registered users and 4 guests