Page 1 of 1

Admin product search problem

Posted: Wed Nov 15, 2017 6:49 am
by arthur
I have noticed that admin product search does not return any results if I search by not the first word of a products. For example, if there is a product CANON EOS 1000 and I type EOS, it returns no results. Is there a way to fix it?

v2.3.0.2

Re: Admin product search problem

Posted: Wed Nov 15, 2017 11:35 am
by IP_CAM
Well, this one should do the Job, as it looks! :D
Ernie
---
Improved Admin Product Filters free, OC v.2.3.0.2:
Simple OCMOD extension to make the searching on Model and Name use any part of the search.
install and it will allow you to use partial searches in model and product name.
There are others available but I wanted to use OCMOD - so this is my version.
Install
1) Download
2) Upload using the Extensions > Extension installer
3) After Installation, clear out all OcMod + VqMod Cache first, then shut down
the Browser, and start it again too, before testing the Site for Results! And
if you see the Page, press Ctrl.+ F5 a few times, to empty any Browser Cache also.
No files are overwritten.
https://www.opencart.com/index.php?rout ... n_id=31225

Re: Admin product search problem

Posted: Wed Nov 15, 2017 4:09 pm
by arthur
IP_CAM wrote:
Wed Nov 15, 2017 11:35 am
Well, this one should do the Job, as it looks! :D
Ernie
---
Improved Admin Product Filters free, OC v.2.3.0.2:
...
Yes, it did the job :)

Re: Admin product search problem

Posted: Wed Dec 05, 2018 3:08 am
by nongetjie
Is there a solution like this for OC 3.0.2.0? Could not find one

Re: Admin product search problem

Posted: Wed Dec 05, 2018 7:13 am
by IP_CAM

Re: Admin product search problem

Posted: Wed Dec 05, 2018 3:24 pm
by nongetjie
IP_CAM wrote:
Wed Dec 05, 2018 7:13 am
checked here already ?
https://www.opencart.com/index.php?rout ... t%20Filter
yes but couldn't find a proper one

Re: Admin product search problem

Posted: Wed Dec 05, 2018 11:38 pm
by Johnathan
OpenCart Admin Improvements should fix this, letting you search by partial values. It also has a bunch of other little improvements to the admin panel, and works on all OpenCart 3.0 versions.

Feel free to take a look at the screenshots and demo site, and if you're interested let me know at www.getclearthinking.com/contact if you have any further questions.

Re: Admin product search problem

Posted: Thu Dec 06, 2018 9:31 pm
by nongetjie
Johnathan wrote:
Wed Dec 05, 2018 11:38 pm
OpenCart Admin Improvements should fix this, letting you search by partial values. It also has a bunch of other little improvements to the admin panel, and works on all OpenCart 3.0 versions.

Feel free to take a look at the screenshots and demo site, and if you're interested let me know at www.getclearthinking.com/contact if you have any further questions.
Looks great, I think you can expect a purchase shortly

Re: Admin product search problem

Posted: Fri Dec 07, 2018 1:48 pm
by moneycarlo
Use the % sign. Its the wildcard. If your product is called "toy car" just type %car in the filter and you'll get the results. No mods needed

Re: Admin product search problem

Posted: Fri Dec 07, 2018 3:41 pm
by nongetjie
moneycarlo wrote:
Fri Dec 07, 2018 1:48 pm
Use the % sign. Its the wildcard. If your product is called "toy car" just type %car in the filter and you'll get the results. No mods needed
tnx that's a good one. But I'm lazy and I like it when it just works without any additional characters

Re: Admin product search problem

Posted: Sun Dec 09, 2018 1:24 am
by xxvirusxx

Re: Admin product search problem

Posted: Mon Dec 10, 2018 7:20 pm
by nongetjie
xxvirusxx wrote:
Sun Dec 09, 2018 1:24 am
@nongetjie

Try this

https://www.opencart.com/index.php?rout ... n_id=32796
Nice one tnx!