Post by hrliakop » Tue May 24, 2016 3:53 pm

Hello to everyone.
All pages of the customer account work except the address book page.
I get a HTTP Error 500.

Can someone help?
OpenCart Version 2.2 (fresh install)

Newbie

Posts

Joined
Tue May 24, 2016 3:51 pm

Post by straightlight » Wed May 25, 2016 6:10 am

If you check in your admin error logs page, can you see the address.php file line where it would indicate an error after trying the address page again?

Tired of paying for service fees to export your database from other databases over Opencart?

Try those extensions for FREE: http://www.opencart.com/index.php?route ... aightlight

Regards,
Straightlight


Expert Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by hrliakop » Fri May 27, 2016 3:53 pm

straightlight wrote:If you check in your admin error logs page, can you see the address.php file line where it would indicate an error after trying the address page again?
There was not any error at the log refering to address.php
Problem was solved by uploading a newer version of address.php from GitHub.
Thank you

Newbie

Posts

Joined
Tue May 24, 2016 3:51 pm

Post by mouseflo5 » Wed Jul 27, 2016 5:10 pm

Thanks, yes this helps! Need to download latest files from Github...
In my case I had problem with customer/customer.php.

Newbie

Posts

Joined
Sat Nov 07, 2015 9:01 pm

Post by straightlight » Wed Jul 27, 2016 6:17 pm

mouseflo5 wrote:Thanks, yes this helps! Need to download latest files from Github...
In my case I had problem with customer/customer.php.
I am not sure I understand if the URL is not posted from the above user especially for customer/customer issue while this topic addresses the issue about index.php?route=account/address ...

Tired of paying for service fees to export your database from other databases over Opencart?

Try those extensions for FREE: http://www.opencart.com/index.php?route ... aightlight

Regards,
Straightlight


Expert Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by tdaubs » Tue Aug 01, 2017 2:44 am

If you're having this issue with Opencart 2.2, replace the address.php file in /catalog/controller/account/ directory.

Replace it with the address.php from Opencart version 2.3.0.2 which should fix the blank / white screen error.

Before you replace the file, make sure to create a db backup and a backup of the original address.php file in case something goes south.

Image
Opencart Support | Opencart Galaxy


User avatar
Active Member

Posts

Joined
Fri Apr 08, 2011 4:51 am
Location - Southern California
Who is online

Users browsing this forum: No registered users and 10 guests