Post by i2Paq » Wed Oct 07, 2015 1:27 am

BUGs should be posted at the OpenCart GitHub Issue tracker.

OpenCart 2.1.0.1

This topic is for clean installs (NO UPGRADE) where issue's occur and you can post your problem here and hopefully your will get an answer.

I will try to sum up all genuine found "bugs" in this start-post.

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

UPGRADE to 2.x: Contemplate before thou begins!

Our FREE search: Find your answer FAST!.

BUGs?: Known BUGS for All OC Versions.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by tjsystems » Wed Oct 07, 2015 7:08 pm

Would like to do that. But most of the issues/pull's are closed without any feedback at all...

Live with 2.2.0.0 fully SSL.


Active Member

Posts

Joined
Sun Aug 26, 2012 5:39 pm
Location - NL, Amsterdam

Post by i2Paq » Wed Oct 07, 2015 9:21 pm

tjsystems wrote:Would like to do that. But most of the issues/pull's are closed without any feedback at all...
Did you check the: v2.1.0.0 (29.09.2015) and v2.1.0.1 (06.10.2015) Bug & Changelog

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

UPGRADE to 2.x: Contemplate before thou begins!

Our FREE search: Find your answer FAST!.

BUGs?: Known BUGS for All OC Versions.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by Sm00dE » Thu Oct 08, 2015 1:17 am

Little mistake but still mistake

On installation

5. Please make sure you have set the correct permissions on the directories list below.
Directories

/home/*****/domains/*******/public_html/system//storage/cache/

Double // on directory

New member

Posts

Joined
Wed Feb 01, 2012 4:32 am

Post by tjsystems » Thu Oct 08, 2015 3:37 am

Thanks i2paq.

Live with 2.2.0.0 fully SSL.


Active Member

Posts

Joined
Sun Aug 26, 2012 5:39 pm
Location - NL, Amsterdam

Post by iamdevice » Wed Oct 14, 2015 9:24 pm

after update i can't view orders
i got error

Code: Select all

Class 'Controllerpayment' not found in /***/system/modification/system/engine/loader.php on line 39
Installed mods Journal 2, ADV Profit, Simple Checkout and seo_pro.
My custom mods don't change loader.php

Line 39 has code

Code: Select all

$controller = new $class($this->registry);

Newbie

Posts

Joined
Wed Oct 14, 2015 9:21 pm

Post by pm-netti » Sun Oct 18, 2015 2:39 am

Is this order issue bug:

http://forum.opencart.com/viewtopic.php?f=181&t=152759

This is also one my client.

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by kulak » Tue Oct 20, 2015 2:49 pm

Clean installation with custom user ID (non admin) resulted in "Permission Denied" for just about every item: "Catalog", Products, profiles, etc.

Newbie

Posts

Joined
Tue Oct 20, 2015 2:47 pm

Post by overthroned » Tue Oct 20, 2015 4:11 pm

Dear All,

So only 5 posts here and tens of fixes in the GitHub.

What is the right way to use 2.1.0.1? How to update?

I can not find any info about this. Will it be 2.1.1.1 with fixes or I should download Master from GitHub to have latest fixes?

Newbie

Posts

Joined
Tue Nov 25, 2014 11:11 pm

Post by kulak » Wed Oct 21, 2015 1:20 pm

kulak wrote:Clean installation with custom user ID (non admin) resulted in "Permission Denied" for just about every item: "Catalog", Products, profiles, etc.
I have reported the issue https://github.com/opencart/opencart/issues/3525

The problem has nothing to do with custom admin name. The same installation procedure works with 2.0.3.1 release, so my newbie status does not apply.

Details are in the report.

Newbie

Posts

Joined
Tue Oct 20, 2015 2:47 pm

Post by kulak » Wed Oct 21, 2015 4:27 pm

kulak wrote:
kulak wrote:Clean installation with custom user ID (non admin) resulted in "Permission Denied" for just about every item: "Catalog", Products, profiles, etc.
I have reported the issue https://github.com/opencart/opencart/issues/3525

The problem has nothing to do with custom admin name. The same installation procedure works with 2.0.3.1 release, so my newbie status does not apply.

Details are in the report.
Reason for issue: Permission system is broken on clean installation if json_decode function is not installed

Newbie

Posts

Joined
Tue Oct 20, 2015 2:47 pm

Post by OSWorX » Wed Oct 21, 2015 4:38 pm

kulak wrote:Reason for issue: Permission system is broken on clean installation if json_decode function is not installed
What strange or old system is that when json_xxxx is not installed/enabled??

Image


User avatar
Expert Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by dwains » Wed Oct 21, 2015 10:59 pm

I get after 2.1.0.1. fresh install with order edit:
[Exception... "<no message>" nsresult: "0x805e0006 (<unknown>)" location: "JS frame :: https://www.ftestestestt.nl/admin/view/ ... 1.1.min.js :: .send :: line 4" data: no]

New member

Posts

Joined
Sat Jun 14, 2014 10:53 pm

Post by overthroned » Thu Oct 22, 2015 6:27 pm

Guys, once again - multiply bugs was reported. What is the guideline to ordinary users to make sure they update/install to latest system with all this bugs fixed?

- 1. install version from http://www.opencart.com/index.php?route ... load_id=42 , and then go trough all the Issue Tracker posts, find commits and apply them to actual system?

- 2. download Master from Github

- 3. wait 2.1.1.1 ....

- 4 ......


Please anybody? I think this is really important question :)
overthroned wrote:Dear All,

So only 5 posts here and tens of fixes in the GitHub.

What is the right way to use 2.1.0.1? How to update?

I can not find any info about this. Will it be 2.1.1.1 with fixes or I should download Master from GitHub to have latest fixes?

Newbie

Posts

Joined
Tue Nov 25, 2014 11:11 pm

Post by i2Paq » Fri Oct 23, 2015 2:56 am

overthroned wrote:Guys, once again - multiply bugs was reported. What is the guideline to ordinary users to make sure they update/install to latest system with all this bugs fixed?

- 1. install version from http://www.opencart.com/index.php?route ... load_id=42 , and then go trough all the Issue Tracker posts, find commits and apply them to actual system?

- 2. download Master from Github

- 3. wait 2.1.1.1 ....

- 4 ......


Please anybody? I think this is really important question :)
overthroned wrote:Dear All,

So only 5 posts here and tens of fixes in the GitHub.

What is the right way to use 2.1.0.1? How to update?

I can not find any info about this. Will it be 2.1.1.1 with fixes or I should download Master from GitHub to have latest fixes?
If you download the latest master from Github you not only get Bugfixes, but also new (and incomplete) changes.

Effortless we tried to get this changed differently.....

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

UPGRADE to 2.x: Contemplate before thou begins!

Our FREE search: Find your answer FAST!.

BUGs?: Known BUGS for All OC Versions.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by overthroned » Fri Oct 23, 2015 3:18 am

i2Paq wrote:
overthroned wrote:Guys, once again - multiply bugs was reported. What is the guideline to ordinary users to make sure they update/install to latest system with all this bugs fixed?

- 1. install version from http://www.opencart.com/index.php?route ... load_id=42 , and then go trough all the Issue Tracker posts, find commits and apply them to actual system?

- 2. download Master from Github

- 3. wait 2.1.1.1 ....

- 4 ......


Please anybody? I think this is really important question :)
overthroned wrote:Dear All,

So only 5 posts here and tens of fixes in the GitHub.

What is the right way to use 2.1.0.1? How to update?

I can not find any info about this. Will it be 2.1.1.1 with fixes or I should download Master from GitHub to have latest fixes?
If you download the latest master from Github you not only get Bugfixes, but also new (and incomplete) changes.

Effortless we tried to get this changed differently.....
Thank you very much for the answer!!

So option 2 is not an option :)

What about option 1 or 3, 4 maybe?

Cheers
O0

Newbie

Posts

Joined
Tue Nov 25, 2014 11:11 pm

Post by moneycarlo » Fri Oct 23, 2015 4:57 am

option 4 is what most of us are doing... :laugh:

Active Member

Posts

Joined
Wed Sep 28, 2011 3:40 am

Post by kulak » Fri Oct 23, 2015 3:55 pm

OSWorX wrote:
kulak wrote:Reason for issue: Permission system is broken on clean installation if json_decode function is not installed
What strange or old system is that when json_xxxx is not installed/enabled??
The system is not strange and is not old. I originally run into the possibility wit this Stack Overflow answer. It listed Debian has removed PHP JSON due to license incompatibility: http://stackoverflow.com/questions/1823 ... son-decode

However, the system I am running is latest FreeBSD running OpenCart in a jailed environment. That means I am starting with nothing installed and have to explicitly install external dependencies. JSON was not listed as a dependency, but forums discussed issues in 2.1 due to JSON which gave me a clue.

Newbie

Posts

Joined
Tue Oct 20, 2015 2:47 pm

Post by Qphoria » Tue Oct 27, 2015 3:16 am

Coupon History Update still seems to be a bug in 2.1.x:
http://forum.opencart.com/viewtopic.php ... 66#p587666

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by dwains » Tue Oct 27, 2015 6:33 pm

dwains wrote:I get after 2.1.0.1. fresh install with order edit:
[Exception... "<no message>" nsresult: "0x805e0006 (<unknown>)" location: "JS frame :: https://www.ftestestestt.nl/admin/view/ ... 1.1.min.js :: .send :: line 4" data: no]
how to fix this? Still have this bug.....

New member

Posts

Joined
Sat Jun 14, 2014 10:53 pm
Who is online

Users browsing this forum: No registered users and 8 guests