Post by fakhricker » Tue Mar 08, 2016 8:56 pm

i thought that was bug for seo but when i installed on the other hosting and domain thats totaly not seo bug
look http://www.blimurah.com/desktops/pc
http://s10.postimg.org/5djueg6s9/withou ... _works.png

but when im installed ssl on my hosting it cant load compelete. Its like .css wont load in ssl mode
https://www.gamio.web.id/desktops/pc
http://s22.postimg.org/gomoisxlt/seo_ssl_not_work.png

but thats became strange when in category i click Show All Desktop in Desktop menu
https://www.gamio.web.id/desktops
http://s27.postimg.org/eldvcuhqb/132.png

Sry for my bad language
:)

Newbie

Posts

Joined
Sun Jan 10, 2016 11:26 pm

Post by daniGo » Tue Mar 08, 2016 9:10 pm

Check if some extension cause this error or try to contact your host.

This is CSS from https://www.gamio.web.id/desktops

https://www.gamio.web.id/catalog/view/j ... ap.min.css

This is CSS from https://www.gamio.web.id/desktops/mac

https://www.gamio.web.id/desktops/catal ... ap.min.css

I don't' know why the site trying to load CSS and JS from https://www.gamio.web.id/desktops/ and not https://www.gamio.web.id/

http://www.gombac.si


Active Member

Posts

Joined
Wed Mar 20, 2013 4:49 pm
Location - Slovenia

Post by fakhricker » Tue Mar 08, 2016 9:35 pm

But when im disabled SEO mode the page load completely
https://www.gamio.web.id/index.php?rout ... path=20_26
Image

this version is standard with standard ext
._.

Newbie

Posts

Joined
Sun Jan 10, 2016 11:26 pm

Post by daniGo » Tue Mar 08, 2016 10:00 pm

On my store i set seo to all urls and all working fine CSS and JS. I don't know why this happen on your store. Try look in .htaccess settings or maybe server settings.

http://www.gombac.si


Active Member

Posts

Joined
Wed Mar 20, 2013 4:49 pm
Location - Slovenia

Post by fakhricker » Tue Mar 08, 2016 10:05 pm

daniGo wrote:On my store i set seo to all urls and all working fine CSS and JS. I don't know why this happen on your store. Try look in .htaccess settings or maybe server settings.
May i look ur link store?
._.

This my htaccess code

Code: Select all

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled.

# 2. In your opencart directory rename htaccess.txt to .htaccess.

# For any support issues please visit: http://www.opencart.com

Options +FollowSymlinks

# Prevent Directoy listing
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "(?i)((\.tpl|\.ini|\.log|(?<!robots)\.txt))">
 Order deny,allow
 Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
RewriteRule ^system/download/(.*) index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

### Additional Settings that may need to be enabled for some servers
### Uncomment the commands by removing the # sign in front of it.
### If you get an "Internal Server Error 500" after enabling any of the following settings, restore the # as this means your host doesn't allow that.

# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
# php_flag register_globals off

# 2. If your cart has magic quotes enabled, This may work to disable it:
# php_flag magic_quotes_gpc Off

# 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try
# php_value upload_max_filesize 999M

# 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value post_max_size 999M

# 5. set max time script can take. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_execution_time 200

# 6. set max time for input to be recieved. Uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_input_time 200

# 7. disable open_basedir limitations
# php_admin_value open_basedir none

Newbie

Posts

Joined
Sun Jan 10, 2016 11:26 pm

Post by Randem » Wed Mar 09, 2016 5:48 am

hi fakhricker,

Possibly some help - http://www.randemsystems.com/support/op ... s-to-work/

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am

Post by fakhricker » Thu Mar 10, 2016 12:11 am

Ok i'll try

Newbie

Posts

Joined
Sun Jan 10, 2016 11:26 pm

Post by daniGo » Thu Mar 10, 2016 2:02 am

I think this is a solution:

Open catalog/controller/startup/startup.php

and after

$this->config->set('config_url', HTTP_SERVER);

add

$this->config->set('config_ssl', HTTPS_SERVER);

http://www.gombac.si


Active Member

Posts

Joined
Wed Mar 20, 2013 4:49 pm
Location - Slovenia

Post by vesel@abv.bg » Fri May 27, 2016 5:32 am

I have the same problem.
Confirm. The last solution works on OpenCart 2.2 with ssl and seo url enabled.

Newbie

Posts

Joined
Fri May 27, 2016 5:29 am

Post by integris » Fri Jun 24, 2016 12:47 am

Just this one change didn't fix it for me, I spent all night working through the different suggestions and have a workin OC 2.2 https/www on all pages solution here: http://stackoverflow.com/questions/3627 ... 3#37996993

Newbie

Posts

Joined
Wed May 18, 2016 4:14 am

Post by stagosal » Sat Oct 01, 2016 5:32 pm

Hello i have installed an SSL certificate on opencart 2.2.0. I finaly have manage do get everything working. Even if i enabled ssl from the admin settings the checkout page was not on https. THe only problem i encounter is that at other pages when https:// is enabled the subdirectoris on SEO urls does not display images or css. I have tried everything. i added
$this->config->set('config_ssl', HTTPS_SERVER); at the sturtup.php file but nothing changed.

My website is canvas-shop.gr. Fore example:

http://canvas-shop.gr/subjects/modern-art/ works
https://canvas-shop.gr/subjects/modern-art/ does not work

https://canvas-shop.gr/subjects works
https://canvas-shop.gr/subjects/ does not work

It is driving me crazy. Because i was thinking to run https on every page.

Newbie

Posts

Joined
Mon Mar 28, 2016 10:35 pm

Post by Randem » Sun Oct 02, 2016 2:30 am

Hi stagosal ,

Running SSL on EVERY Page is the way to go. Google is thinking of penalizing sites that are not totally HTTPS. It is also bad for customer confidence not to be totally HTTPS. SSL is meant to work on your whole site not part of it. You need code changes to administer SSL. You need to change your .htaccess and OpenCart software.

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am

Post by EvolveWebHosting » Sun Oct 09, 2016 12:05 am

stagosal wrote:Hello i have installed an SSL certificate on opencart 2.2.0. I finaly have manage do get everything working. Even if i enabled ssl from the admin settings the checkout page was not on https. THe only problem i encounter is that at other pages when https:// is enabled the subdirectoris on SEO urls does not display images or css. I have tried everything. i added
$this->config->set('config_ssl', HTTPS_SERVER); at the sturtup.php file but nothing changed.

My website is canvas-shop.gr. Fore example:

http://canvas-shop.gr/subjects/modern-art/ works
https://canvas-shop.gr/subjects/modern-art/ does not work

https://canvas-shop.gr/subjects works
https://canvas-shop.gr/subjects/ does not work

It is driving me crazy. Because i was thinking to run https on every page.
Give this a try in your .htaccess file and then update both config files for SSL.

http://stackoverflow.com/questions/2141 ... h-from-url

Image
https://www.evolvewebhost.com
Unhappy with your current host? We can migrate your account today (usually for no fee)! Visit our website and signup and we'll take care of the rest!
24/7/365 support
Image


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA

Post by stagosal » Tue Oct 18, 2016 4:42 pm

I really want to enable SSL at all pages but you see what i encounter. The homepage works with SSL.
A directory link works ex. https://canvas-shop.gr/subjects
But all directories from that point do not load the css and images. https://canvas-shop.gr/subjects/modern-art
Try it out.

No css is not loaded with 404 error:
https://canvas-shop.gr/subjects/modern- ... ?j2v=2.7.1 Failed to load resource: the server responded with a status of 404 ()
As you can see it adds "/subjects/modern-art/" before "/catalog/view/........"

The correct filepath of the css should be "https://canvas-shop.gr/catalog/view/the ... ?j2v=2.7.1"

Attachments

error.jpg

error.jpg (102.09 KiB) Viewed 3143 times


Newbie

Posts

Joined
Mon Mar 28, 2016 10:35 pm

Post by stagosal » Tue Nov 01, 2016 2:52 am

bump

Newbie

Posts

Joined
Mon Mar 28, 2016 10:35 pm

Post by IP_CAM » Tue Nov 01, 2016 4:15 am

check here:
https://www.opencart.com/index.php?rout ... n_id=26740
and here:
http://www.fastcomet.com/tutorials/opencart2/enable-ssl

so, you possibly find a valid answer on this...
Good Luck!
Ernie

Ernie's OpenCart v.1.5.6.5 LIGHT + V-Pro + OpenShop Admin v.1.75 Test Sites
http://www.bigmax.ch - http://www.opencart.li/shop/ - http://www.velomech.ch/cart/
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by ndim_pro » Tue Jun 12, 2018 8:32 pm

daniGo wrote:
Thu Mar 10, 2016 2:02 am
I think this is a solution:

Open catalog/controller/startup/startup.php

and after

$this->config->set('config_url', HTTP_SERVER);

add

$this->config->set('config_ssl', HTTPS_SERVER);
Your solution, this row of code gave an end to two days of absolute frustration for me.
Thank you!!!

User avatar
New member

Posts

Joined
Fri Nov 04, 2016 4:49 pm
Who is online

Users browsing this forum: No registered users and 5 guests