Post by Rainforest » Wed Jan 09, 2019 9:03 am

We've had this issue on and off again for years.

Sometimes, when I user changes an order status from say Confirmed to our next one which is custom called Warehouse Processing, the status changes instead to REVIEW.
We then try to change it and we can't.
So, I have to go manually into the database to change the order status.

I've already:
1. Made a new user group and new user
2. Tried to replicate the issue and it happened.

It doesn't happen to some users but others it does.

Any ideas as to what might cause this?

Active Member

Posts

Joined
Fri Jan 28, 2011 3:50 am

Post by OSWorX » Fri Jan 11, 2019 1:20 am

It would be good to find out:

1. which OpenCart Version
2. which Browser (always the same or different)
3. in which view (mobile, desktop)
4. on which position in the dropdown are these 2 entries (close to each other)
5. maybe 2 status entries with the same

You see - as always, more details are required to find out what is going on (if something is going wrong).

Forum Rules [en]: viewtopic.php?f=176&t=200480
Forumregeln [de]: viewtopic.php?f=37&t=114208
Commercial Request: viewforum.php?f=88

Image


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by Rainforest » Fri Jan 11, 2019 11:13 am

Thanks. I actually figured it out. It's a well known bug in OC 2.x
It has to do with coupons and how the system treats them.
I applied the fixes here to solve my orders going to a REVIEW status and getting stuck there unless I go into the database and change their status_id.
https://github.com/opencart/opencart/is ... -174047947

Active Member

Posts

Joined
Fri Jan 28, 2011 3:50 am
Who is online

Users browsing this forum: No registered users and 18 guests