Post by onoriotorti » Tue Sep 04, 2018 4:12 pm

Hi everyone,
I've been having this little issue since all my website pages have been converted to HTTPS.
I've modified the config.php files and the .htaccess and managed to do so but now all my website URL show (index.php?_route_=) right after the domain name.

I have removed this issue by adding the following lines inside the .htaccess

RewriteCond %{THE_REQUEST} \ /index\.php\?_route_=?([^&\ ]*)
RewriteRule ^ /%1? [L,R]

The only problem is that removing (index.php?_route_=) from the URL gives errors when a subcategory is opened (see image1)

so basically I dont want (index.php?_route_=) to show in the URL but I need it to, or the page is shown all broken.

So my question is:
is there a way to fix this so that the URL is clean and the pages will show correctly? the problem only happens when when i reach a subcategory, the main categories work fine.

Please any help would be appriciated.

Ps.

I'm using version 2.2 of OC
my website is https://www.cattex.com/
I have also attached my .htaccess file.

Attachments

image1.JPG

image1.JPG (65.43 KiB) Viewed 591 times


New member

Posts

Joined
Tue Jun 20, 2017 5:36 pm

Post by straightlight » Tue Sep 04, 2018 7:51 pm

There are countless SEO link extensions you could use from the Marketplace and even for free to solved this inquiry.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by onoriotorti » Tue Sep 04, 2018 7:56 pm

Thank you for the reply.
I know for certain the truble is with the way the .htaccess file is been setup so i tought fixing that would also fix the issue, but i don't have the skill to figure it out by myself. (lol)
But if you tell me a free extension would solve this issue i will defenetely go with that option, can you point me in the direction of one of them?

New member

Posts

Joined
Tue Jun 20, 2017 5:36 pm

Post by MrPhil » Tue Sep 04, 2018 8:11 pm

Was it working properly (SEO-friendly URLs) before you changed to all-https, and something broke in the process, or have you never had SEO-friendly URLs and you now want to add them?

User avatar
Active Member

Posts

Joined
Wed May 10, 2017 11:52 pm

Post by straightlight » Tue Sep 04, 2018 8:13 pm

But if you tell me a free extension would solve this issue i will defenetely go with that option, can you point me in the direction of one of them?
Definitely, yes. By filtering the search with the most stars rated in the Marketplace and look for seo links with the search text box, filtered as Free, it should already be easy to find the most relative extensions - also by reading their comments.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by onoriotorti » Tue Sep 04, 2018 8:19 pm

MrPhil wrote:
Tue Sep 04, 2018 8:11 pm
Was it working properly (SEO-friendly URLs) before you changed to all-https, and something broke in the process, or have you never had SEO-friendly URLs and you now want to add them?
Yes I had SEO-friendly URLs before the change.

New member

Posts

Joined
Tue Jun 20, 2017 5:36 pm

Post by onoriotorti » Tue Sep 04, 2018 8:21 pm

Definitely, yes. By filtering the search with the most stars rated in the Marketplace and look for seo links with the search text box, filtered as Free, it should already be easy to find the most relative extensions - also by reading their comments.
[/quote]
ok I'll Definitely ;) try that

New member

Posts

Joined
Tue Jun 20, 2017 5:36 pm

Post by straightlight » Tue Sep 04, 2018 8:24 pm

No problem. However, if you had a previous SEO extension installed, it would be highly suggested to remove it first before installing a new extension or fixing the previous extension codes.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by onoriotorti » Tue Sep 04, 2018 10:12 pm

straightlight wrote:
Tue Sep 04, 2018 8:24 pm
No problem. However, if you had a previous SEO extension installed, it would be highly suggested to remove it first before installing a new extension or fixing the previous extension codes.
Ok so I tried what you said but with no result.
Also let's remember that the real issue in this case is not the index.php? inside the URL I was already able to remove it, but the fact that without the index.php? in the URL subcategories are shown broken (image1)

why is that? and why only the subcategories?

Attachments

image1.JPG

image1.JPG (65.43 KiB) Viewed 502 times


New member

Posts

Joined
Tue Jun 20, 2017 5:36 pm

Post by straightlight » Tue Sep 04, 2018 10:15 pm

SEO extension issues or modifications has been made afterwards in the .htaccess file while the extension was working prior which is why it was also suggested to look for other extensions on the Marketplace. In addition, you can also contact the extension developer to resolved the current issue.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by onoriotorti » Wed Sep 05, 2018 10:58 pm

straightlight wrote:
Tue Sep 04, 2018 10:15 pm
SEO extension issues or modifications has been made afterwards in the .htaccess file while the extension was working prior which is why it was also suggested to look for other extensions on the Marketplace. In addition, you can also contact the extension developer to resolved the current issue.
What I tried was to disable the friendly SEOurl.xml and install a different seo extension but nothing happened.
Yeah I might just contact the developer and see what he says, will probably need to renew the extension support, unless we can figure something out.
so basically fixing the SEO extension will also stop the subcategories from going into error, right?
Thanks,

New member

Posts

Joined
Tue Jun 20, 2017 5:36 pm

Post by straightlight » Wed Sep 05, 2018 11:42 pm

so basically fixing the SEO extension will also stop the subcategories from going into error, right?
An accurate answer on this question can't be provided since this issue is related to a contributed extension.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 13 guests