Post by Rainforest » Sun Jun 10, 2018 8:12 pm

OC 2.3.0.2
Journal Theme

My contact form started giving "verification is not correct"
I get the green check mark that the recaptcha is fine but when I hit submit I get the error

I read the forum and couldn't find anything.
I did the following:
1. checked to make sure fcurl is open on hosting and php.ini
2. deleted recaptcha keys and reinstalled recaptcha
3. Compared a working google recaptcha.php on my other site to this one

Sort of stuck and confused why even though I the green checkmark, I still get the Verification is not correct error when I hit submit.
Last edited by Rainforest on Mon Jun 11, 2018 1:19 am, edited 1 time in total.

Active Member

Posts

Joined
Fri Jan 28, 2011 3:50 am

Post by straightlight » Sun Jun 10, 2018 8:17 pm

This solution may fix the issue: https://github.com/opencart/opencart/issues/6641

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Rainforest » Mon Jun 11, 2018 1:20 am

Thank you for your reply but no, that didn't have anything to do with my issue.
I did however solve it on my own.

I compared every thing from my working site to this site.
I noticed that the non-working was running php 5.4 and the working was running 5.5
I switched to 5.5 and now the google recaptcha works.

Active Member

Posts

Joined
Fri Jan 28, 2011 3:50 am

Post by straightlight » Mon Jun 11, 2018 11:46 pm

Opencart PHP minimum requirement is now at PHP v5.6, according to GitHub Opencart nowadays.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 34 guests