Post by geniusroi » Sat May 26, 2018 8:08 pm

I recently noticed that all product images gives this error when I click on them.

When I inspect the errors, I see this line

Code: Select all

Notice: Undefined variable: href in /home4/consult/public_html/hejazoud/system/storage/modification/catalog/view/theme/my/template/product/product.tpl  on line  49

That's the code for this line:

Code: Select all

                    <li class="image-sm"> <!--Zoom image by Nilkathinfo start-->
                        <a class="thumbnail" href="<?=$href?>" title="">
                            <img src="<?=$thumb?>" title="" alt="" id="image">
                        </a>
                    </li>
Here's an example page: http://www.hejazoud.net/index.php?route ... uct_id=445

OpenCart Version 2.2.0.0

Newbie

Posts

Joined
Sun Mar 26, 2017 8:29 pm

Post by yodapt » Sat May 26, 2018 8:17 pm

That error is created by a modification you installed.

Opencart Developer - My Extension Showcase
Contact me at aeon.yoda@gmail.com


User avatar
Active Member

Posts

Joined
Fri Jun 17, 2011 6:39 pm


Post by geniusroi » Sat May 26, 2018 8:25 pm

yodapt wrote:
Sat May 26, 2018 8:17 pm
That error is created by a modification you installed.
I disabled all installed modifications. Still the same error.

Newbie

Posts

Joined
Sun Mar 26, 2017 8:29 pm

Post by yodapt » Sat May 26, 2018 8:33 pm

To restore everything you need to disable and clear modifications cache, otherwise those files will still be there.

I suggest you enable them one by one, clearing cache in between, until you find the extension responsible for the error.

Opencart Developer - My Extension Showcase
Contact me at aeon.yoda@gmail.com


User avatar
Active Member

Posts

Joined
Fri Jun 17, 2011 6:39 pm


Post by geniusroi » Sat May 26, 2018 8:45 pm

yodapt wrote:
Sat May 26, 2018 8:33 pm
To restore everything you need to disable and clear modifications cache, otherwise those files will still be there.

I suggest you enable them one by one, clearing cache in between, until you find the extension responsible for the error.
I did just that. Disabled all of them, clicked refresh and clear. I even clicked Empty cache and Hard Reload in the browser.

I think the problem is the code above because when I hover in the images the link is the error "Notice: Undefined variable: href in /home4/consult/public_html/hejazoud/system/storage/modification/catalog/view/theme/my/template/product/product.tpl on line 49" instead of an actual link.

So, maybe the error with "<?=$href?>" or "<?=$thumb?>".

Newbie

Posts

Joined
Sun Mar 26, 2017 8:29 pm

Post by yodapt » Sat May 26, 2018 8:58 pm

PM me if you need further assistance.

Opencart Developer - My Extension Showcase
Contact me at aeon.yoda@gmail.com


User avatar
Active Member

Posts

Joined
Fri Jun 17, 2011 6:39 pm


Post by geniusroi » Sat May 26, 2018 9:00 pm

yodapt wrote:
Sat May 26, 2018 8:58 pm
PM me if you need further assistance.
I fixed it by replacing the referenced line with the thumnail code from the default theme

Code: Select all

 <li><a class="thumbnail" href="<?php echo $popup; ?>" title="<?php echo $heading_title; ?>"><img src="<?php echo $thumb; ?>" title="<?php echo $heading_title; ?>" alt="<?php echo $heading_title; ?>" /></a></li>
 
Anyway, thanks for your help.

Newbie

Posts

Joined
Sun Mar 26, 2017 8:29 pm
Who is online

Users browsing this forum: No registered users and 11 guests