Post by Qphoria » Fri May 25, 2018 2:29 am

It's a common misconception that the payment extensions are the entity that needs update. While there is a setting that could cause issues, most mods just use the default settings for curl calls which would use the webhost's decision of transport layer.
https://stackoverflow.com/questions/301 ... ng-in-curl

So it really comes down to your host being up to date.
Most hosts have been supporting TLS 1.2 for years. To check if your host is up to date, use this site:
https://www.sha2sslchecker.com

But as far as code goes.. unless the payment extension has an explicit curl setting like this:

Code: Select all

curl_setopt($ch, CURLOPT_SSLVERSION, 3);
or

Code: Select all

curl_setopt($ch, CURLOPT_SSLVERSION, CURL_SSLVERSION_TLSv1_1);
You will not need to alter anything. I've yet to find any payment mods using that call so you should be just fine.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am
Who is online

Users browsing this forum: No registered users and 9 guests