Post by Kromak » Thu Mar 08, 2018 9:09 pm

Hi everyone, I have an issue with shipping and taxes not working in the cart. No matter what you enter on the region/state and postcode it throws up the errors "Please select a region / state!" and "Postcode must be between 2 and 10 characters!". The shipping works fine when you go to checkout however.

Any help would be most appreciated :)

Newbie

Posts

Joined
Thu Mar 08, 2018 9:04 pm

Post by straightlight » Fri Mar 09, 2018 8:19 pm

No OC version posted.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Kromak » Fri Mar 09, 2018 10:42 pm

Sorry, its 2.3.0.2

Newbie

Posts

Joined
Thu Mar 08, 2018 9:04 pm

Post by Johnathan » Sat Mar 10, 2018 12:35 am

I've seen this issue before if you have another shipping estimator on that page, or another module that uses the same ID's for the HTML elements. When you estimate, it gets the values from the *other* module, which are blank --- that's why it doesn't work.

Try checking your cart page source code to see if you can find other elements that have the ID "postcode", and see if that leads you to the right module. You can then disable/remove it from that page, so it doesn't affect the normal shipping estimator.

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by Kromak » Wed Mar 14, 2018 11:27 pm

Thanks for the reply. I installed a new theme in January and I know it was working before this. I'll pass on your comments to the theme developers to see if they can fix it. Many thanks.

Newbie

Posts

Joined
Thu Mar 08, 2018 9:04 pm
Who is online

Users browsing this forum: No registered users and 83 guests