Post by aleksandra1981 » Tue Feb 13, 2018 6:45 pm

Hallo, I cannot access the custom page in admin part of the site. I want it to be stand alone, and appearing in the main menu bulk. Not in modules. What I did:

1.I'm trying to build a new component in the open cart 2.0.3.1. I have created files in
admin/controller/mycomponent/mycomponent.php
admin/model/mycomponent/mycomponent.php
admin/language/english/mycomponent/mycomponent.php
(and a couple of template files):
admin/view/template/mycomponent/list_view.tpl
admin/view/template/mycomponent/custom_form.tpl

the index function in controller should load data in list_view.tpl

2. Then I have checked the boxes in Configuration->groups->permissions

3. I try to access the page by /admin/index.php?route=mycomponent/mycomponent&token=c167b51658c5e4b6a96bfc6247920b1c

4. I get the page with the acess denied message.

I have installed the files manualy via FTP.

I have searched for a couple of days from now, but cannot find the answer how to fix this or what am I doing wrong. Can anyone point me the way out? Really appreciate any help!


Posts

Joined
Fri Mar 17, 2017 10:49 pm

Post by straightlight » Wed Feb 14, 2018 7:04 am

Ensure to have set proper permissions in your admin - > systems - > users - > user groups page. Your custom controller file should be listed into both text areas.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: gunner86 and 21 guests