Post by WavMixer » Fri Jan 12, 2018 3:37 am

Running Opencart 2.0.3.2 with default theme. When customers go to checkout their item, they get the following error...

Fatal error: Call to a member function getElementsByTagName() on null in /home/keyboard2/www/opencart-2_3_0_2b/catalog/model/extension/shipping/ups.php on line 243 at Step 4 - Delivey Method

User avatar
New member

Posts

Joined
Sun Feb 23, 2014 3:15 am


Post by straightlight » Fri Jan 12, 2018 6:24 am

Using an old version of Opencart. Lots of changes have been made to the modules on more recent versions as I would suggest to upgrade.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Johnathan » Sat Jan 13, 2018 1:11 am

Do you mean OpenCart 2.3.0.2? The error you mention has the "extension" sub-directory, which is only in OpenCart 2.3 and 3.0. I assume you just mistyped that, since the directory name is also "opencart-2_3_0_2b".

If you're using OpenCart 2.3.0.2, then that error looks to be referencing this line:

Code: Select all

$response = $rating_service_selection_response->getElementsByTagName('Response')->item(0);

The error is saying that $rating_service_selection_response is null, which means there is no response from UPS. I don't think there are any bugs in UPS in 2.3, so you probably don't have it set up right. Double-check all your settings, and try playing around with some of them to see if you can figure out which one is causing the issue. You might also turn on Debug mode, to record what the API requests/responses are.

Image
Image Image Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by WavMixer » Sat Jan 13, 2018 1:16 am

Correct, I did have a typo and the correct version is 2.3.0.2. I also discovered what was causing the error. Thank you.

User avatar
New member

Posts

Joined
Sun Feb 23, 2014 3:15 am

Who is online

Users browsing this forum: No registered users and 14 guests