Post by garygajesjr » Mon Nov 20, 2017 11:25 am

Hi I'm encountering this error in my cpanel:
[Mon Nov 20 11:20:41.792249 2017] [:error] [pid 5905] [client 122.54.5.34:37641] client denied by server configuration: /home/acrcomph/agcoop.acr.com.ph/index.php, referer: http://agcoop.acr.com.ph/index.php?rout ... t/checkout

I have this in my .htaccess:
# Prevent Direct Access to files
<FilesMatch "(?i)((\.tpl|\.ini|\.log|(?<!robots)\.txt))">
Require all denied
## For apache 2.2 and older, replace "Require all denied" with these two lines :
# Order deny,allow
# Deny from all
</FilesMatch>

in my checkout page, it show some error not found....
but still going on and completing the checkout when I click OK

Anyone encountered this? I also display error off in php.ini and in admin panel of my cart but still the error is showing

New member

Posts

Joined
Sun Mar 05, 2017 9:18 pm

Post by straightlight » Mon Nov 20, 2017 11:27 am

Followed are some tips on how to resolve this issue: https://stackoverflow.com/questions/841 ... figuration

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by garygajesjr » Mon Nov 20, 2017 11:36 am

Hi,

I tried to use require all denied and granted in apache 2.4, also in 2.2 and older I tried Order deny,allow
Deny from all
AND
Allow from all
Order Deny,Allow

I try this cause I don't know how to check my Apache version but still getting the error in my checkout page and in my cpanel errors

New member

Posts

Joined
Sun Mar 05, 2017 9:18 pm

Post by garygajesjr » Mon Nov 20, 2017 2:35 pm

Anyone can help me please?

New member

Posts

Joined
Sun Mar 05, 2017 9:18 pm

Post by paulfeakins » Mon Nov 20, 2017 8:20 pm

  • What version of OpenCart?
  • What theme?
  • What extensions?

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Active Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom

Post by garygajesjr » Tue Nov 21, 2017 9:52 am

Hi Paul,

I'm using OC v.2.3
just a simplica theme and import to excel extension,

still encountering this issue,
please guide me,
http://agcoop.acr.com.ph
getting not found... error in my checkout process even though I disabled display error in php.ini and in admin panel,
but when you click OK you can still complete the checkout process.

New member

Posts

Joined
Sun Mar 05, 2017 9:18 pm

Post by straightlight » Tue Nov 21, 2017 10:25 am

Switch back to the default theme and see if you can replicate this issue.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by garygajesjr » Tue Nov 21, 2017 11:25 am

Hi,

I think this is due to my hosting,
I upload and install a clean opencart 3 in a free hosting site, then it runs smoothly without any error,
while in my paid hosting I updated to opencart3 clean install and still encountering this issue.
here is my paid hosting site: http://agcoop.acr.com.ph
and here is my free hosting site: http://garyg.elementfx.com

You can try to purchase any item then continue to checkout page, then the error will come out,
in my free hosting it runs without any error

New member

Posts

Joined
Sun Mar 05, 2017 9:18 pm

Post by straightlight » Tue Nov 21, 2017 11:33 am

I just tried an order. After submitting the billing details from checkout on your paid website, I do see the forbidden error message. Can you provide the most recent webserver's access logs regarding the checkout route?

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by garygajesjr » Tue Nov 21, 2017 11:45 am

Hi,

here's my recent error logs in cpanel:
[Tue Nov 21 11:30:50.741573 2017] [:error] [pid 29359] [client 70.55.184.88:57845] client denied by server configuration: /home/acrcomph/agcoop.acr.com.ph/index.php, referer: http://agcoop.acr.com.ph/index.php?rout ... t/checkout
[Tue Nov 21 11:28:30.648666 2017] [:error] [pid 23466] [client 122.54.5.34:12933] client denied by server configuration: /home/acrcomph/agcoop.acr.com.ph/index.php, referer: http://agcoop.acr.com.ph/index.php?rout ... t/checkout
[Tue Nov 21 11:24:13.702059 2017] [:error] [pid 3843] [client 122.54.5.34:31127] client denied by server configuration: /home/acrcomph/agcoop.acr.com.ph/index.php, referer: http://agcoop.acr.com.ph/index.php?rout ... t/checkout
[Tue Nov 21 11:19:02.988063 2017] [:error] [pid 29035] [client 122.54.5.34:30036] client denied by server configuration: /home/acrcomph/agcoop.acr.com.ph/index.php, referer: http://agcoop.acr.com.ph/index.php?rout ... t/checkout
[Tue Nov 21 11:19:02.818246 2017] [:error] [pid 29035] [client 122.54.5.34:30036] client denied by server configuration: /home/acrcomph/agcoop.acr.com.ph/index.php, referer: http://agcoop.acr.com.ph/index.php?rout ... t/checkout
[Tue Nov 21 11:09:05.549577 2017] [:error] [pid 18789] [client 122.54.5.34:46452] client denied by server configuration: /home/acrcomph/agcoop.acr.com.ph/index.php, referer: http://agcoop.acr.com.ph/index.php?rout ... t/checkout
[Tue Nov 21 10:59:16.797768 2017] [:error] [pid 415] [client 122.54.5.34:47587] client denied by server configuration: /home/acrcomph/agcoop.acr.com.ph/index.php, referer: http://agcoop.acr.com.ph/index.php?rout ... t/checkout
[Tue Nov 21 10:59:16.624827 2017] [:error] [pid 415] [client 122.54.5.34:47587] client denied by server configuration: /home/acrcomph/agcoop.acr.com.ph/index.php, referer: http://agcoop.acr.com.ph/index.php?rout ... t/checkout

New member

Posts

Joined
Sun Mar 05, 2017 9:18 pm

Post by straightlight » Tue Nov 21, 2017 10:32 pm

Contact your paid host to resolve this issue.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by garygajesjr » Wed Nov 22, 2017 8:10 am

Hi,

I already contacted their support,
still cant fix the issue...

New member

Posts

Joined
Sun Mar 05, 2017 9:18 pm

Post by straightlight » Wed Nov 22, 2017 8:12 am

If even the host can't resolve this issue, then it would be best suggested to find a host that will be able to professionally manage their domains as well as to maintain web platforms on their servers.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by garygajesjr » Wed Nov 22, 2017 11:45 am

Hi,

Due to we cant resolve this issue,
I tried to installed another platform which is pretashop, and it seems to be working fine, so far I got no errors encountered.
I cant transfer to another hosting site due to I already paid for it, and im just using its subdomain

New member

Posts

Joined
Sun Mar 05, 2017 9:18 pm
Who is online

Users browsing this forum: arthur, christogonus and 50 guests