Post by onoriotorti » Fri Nov 17, 2017 6:46 pm

Hi guys, ok i'm posting way too much here :)
I have a question maybe it's an easy fix but i wasn't able to do it.

You know how you can set additional e-mails to recive alerts when an order arrives right?
well for me it doesn't work.

System>Settings>My Store>Mail>Additional alert e-mails
Inside that box i have 3 additional e-mail set up (all comma separated) but only the first one recives the actual e-mail the rest don't.
is there a way to fix this? am I doing something wrong?

Thanks in advance.

Onorio

New member

Posts

Joined
Tue Jun 20, 2017 5:36 pm

Post by straightlight » Fri Nov 17, 2017 8:38 pm

is there a way to fix this?
Yes.
am I doing something wrong?
Yes, your OC version has not been posted as well as your your admin - > system - > maintenance - > error logs and / or your access log entries from your root FTP logs/access_log file with recent lines regarding email activities.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by onoriotorti » Mon Nov 20, 2017 9:01 pm

my version is 2.2 i have serched the error log but couldn't find anything related to mail.
anyway i have attached it if you want to check it out, had to zip it for some reason the forum doesn't get .txt files.

New member

Posts

Joined
Tue Jun 20, 2017 5:36 pm

Post by straightlight » Mon Nov 20, 2017 10:47 pm

Check the access logs in your root FTP logs/access_log or from your host console. Do you see any recent messages regarding mail activities handled by Opencart? 'Anyway' does not help understand the source of the problem you are reporting about.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by onoriotorti » Mon Nov 20, 2017 10:55 pm

The log in the root directory is empty (see image)

Attachments

log in root.JPG

log in root.JPG (23.78 KiB) Viewed 103 times


New member

Posts

Joined
Tue Jun 20, 2017 5:36 pm

Post by straightlight » Mon Nov 20, 2017 11:00 pm

If the logs are totally empty from the directory, it is possible that your logs are disabled from your host console. See if you can enable them in order to troubleshoot this issue. If you don't know how, contact your host support in order to have them activated.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by onoriotorti » Wed Nov 22, 2017 6:08 pm

Ok so i have found were opencart 2.2 stores the logs. Unfortunately the error log was too big and i couldn't even open it so i cleard it and waited to fill with some errors. I just checked but none of them are regarding mail.

Code: Select all

2017-11-21 10:17:59 - PHP Notice:  Undefined index: key in /var/www/html/cattex/opencart_new/web/catalog/controller/api/login.php on line 11
2017-11-21 10:18:04 - PHP Notice:  Undefined index: key in /var/www/html/cattex/opencart_new/web/catalog/controller/api/login.php on line 11
2017-11-21 10:18:06 - PHP Notice:  Undefined index: key in /var/www/html/cattex/opencart_new/web/catalog/controller/api/login.php on line 11
2017-11-21 13:59:22 - PHP Notice:  Undefined index: product_id in /var/www/html/cattex/opencart_new/web/vqmod/vqcache/vq2-system_storage_modification_catalog_controller_product_product.php on line 87
2017-11-21 13:59:22 - PHP Notice:  Undefined index: option_value_id in /var/www/html/cattex/opencart_new/web/vqmod/vqcache/vq2-system_storage_modification_catalog_controller_product_product.php on line 88
2017-11-21 13:59:22 - PHP Notice:  Undefined index: heading_title in /var/www/html/cattex/opencart_new/web/vqmod/vqcache/vq2-system_storage_modification_catalog_controller_product_product.php on line 89
2017-11-21 13:59:28 - PHP Notice:  Undefined index: product_id in /var/www/html/cattex/opencart_new/web/vqmod/vqcache/vq2-system_storage_modification_catalog_controller_product_product.php on line 87
2017-11-21 13:59:28 - PHP Notice:  Undefined index: option_value_id in /var/www/html/cattex/opencart_new/web/vqmod/vqcache/vq2-system_storage_modification_catalog_controller_product_product.php on line 88
2017-11-21 13:59:28 - PHP Notice:  Undefined index: heading_title in /var/www/html/cattex/opencart_new/web/vqmod/vqcache/vq2-system_storage_modification_catalog_controller_product_product.php on line 89
thanks for the help.

New member

Posts

Joined
Tue Jun 20, 2017 5:36 pm

Post by straightlight » Wed Nov 22, 2017 7:09 pm

These logs shows persistent errors caused by an installed VQMod extension. I would also suggest to disable each XML files until these logs won't appear afterwards. As for the emails, view the access logs from your root FTP logs folder or from your host console in the logs icon for recent email activities.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 61 guests