Post by masterross » Sun Jul 23, 2017 11:57 pm

Hi,
I'm trying for at least 2 weeks to setup SMTP but nothing works :(
I'm using gmail settings:

SMTP Hostname: tls://smtp.gmail.com
SMTP Username: myname@gmail.com
SMTP Password: mypass
SMTP Port: 587

but every time i'm getting :
Warning: stream_socket_enable_crypto(): Peer certificate CN=`mydomain.com' did not match expected CN=`smtp.gmail.com' in /home/ladylen/public_html/system/library/mail.php on line 221

Any ideas whats wrong?
And how to fix it?

Newbie

Posts

Joined
Mon Jan 02, 2017 7:07 pm

Post by kevinbarnes » Tue Nov 14, 2017 9:35 pm

I am also facing the same issue. Did you try to get this fixed.

Newbie

Posts

Joined
Sat Jul 09, 2016 2:22 pm

Post by straightlight » Tue Nov 14, 2017 9:39 pm

Follow these steps and see if that rectifies the issue: viewtopic.php?f=181&t=183198&p=702044#p674746

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by kevinbarnes » Tue Nov 14, 2017 10:07 pm

Hi Thanks I tried now. when i register it goes to blank page :(
received following error

2017-11-14 14:05:54 - PHP Warning: fsockopen(): Failed to enable crypto in /home/adprpcim/public_html/system/library/mail.php on line 170
2017-11-14 14:05:54 - PHP Warning: fsockopen(): unable to connect to ssl://smtp.gmail.com:465 (Unknown error) in /home/adprpcim/public_html/system/library/mail.php on line 170
2017-11-14 14:05:54 - PHP Notice: Error: (0) in /home/adprpcim/public_html/system/library/mail.php on line 173

Newbie

Posts

Joined
Sat Jul 09, 2016 2:22 pm

Post by kevinbarnes » Tue Nov 14, 2017 10:11 pm

If i use tls:// and port 587.
Received following error
PHP Warning: stream_socket_enable_crypto(): Peer certificate CN=`server.dronozone.com' did not match expected CN=`smtp.gmail.com' in /home/adprpcim/public_html/system/library/mail.php on line 221

Newbie

Posts

Joined
Sat Jul 09, 2016 2:22 pm

Post by straightlight » Tue Nov 14, 2017 10:44 pm

Contact your host about this issue.

Source: https://stackoverflow.com/questions/453 ... did-not-ma

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by webcorvo » Tue Nov 14, 2017 10:58 pm

straightlight wrote:
Tue Nov 14, 2017 10:44 pm
Contact your host about this issue.

Source: https://stackoverflow.com/questions/453 ... did-not-ma
Yep, seams like a permissions issue ..

Opencart Developer, custom work and support.
Contact - webcorvo@gmail.com


User avatar
Active Member

Posts

Joined
Mon Mar 20, 2017 11:42 pm
Location - Lisbon, Portugal

Post by straightlight » Tue Nov 14, 2017 11:21 pm

webcorvo wrote:
Tue Nov 14, 2017 10:58 pm
straightlight wrote:
Tue Nov 14, 2017 10:44 pm
Contact your host about this issue.

Source: https://stackoverflow.com/questions/453 ... did-not-ma
Yep, seams like a permissions issue ..
You don't need to repeat what's already been provided above ...

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by webcorvo » Tue Nov 14, 2017 11:53 pm

straightlight wrote:
Tue Nov 14, 2017 11:21 pm
webcorvo wrote:
Tue Nov 14, 2017 10:58 pm
straightlight wrote:
Tue Nov 14, 2017 10:44 pm
Contact your host about this issue.

Source: https://stackoverflow.com/questions/453 ... did-not-ma
Yep, seams like a permissions issue ..
You don't need to repeat what's already been provided above ...
sorry :(

Opencart Developer, custom work and support.
Contact - webcorvo@gmail.com


User avatar
Active Member

Posts

Joined
Mon Mar 20, 2017 11:42 pm
Location - Lisbon, Portugal

Post by Tajx » Wed Nov 15, 2017 1:09 am

configure:
Protocol Mail
SMTM : smtp.gmail.com
SMTP username: Your full Gmail or Google Apps email address
SMTP password: Your Gmail or Google Apps email password
SMTP port: 465
save settings.
after this
add this line to both root and admin php.ini files.
sendmail_path = /usr/sbin/sendmail -t -i;
enjoy!

New member

Posts

Joined
Wed Aug 15, 2012 4:18 pm
Who is online

Users browsing this forum: No registered users and 47 guests