Post by santura » Tue Jul 05, 2016 3:09 pm

If I add an item to the cart and then go to either the home page or the contact page and open the minicart with the button and then remove the item, the cart empties, and the button says loading but it is not updated and the item still shows on the button. Only after reloading the page will it update.
Screenshot_13.jpg

Screenshot_13.jpg (6.66 KiB) Viewed 540 times

On other pages it updates properly without reloading the page.

New member

Posts

Joined
Fri Jun 14, 2013 8:33 pm

User avatar
Active Member

Posts

Joined
Sun May 11, 2014 2:04 pm


Post by santura » Tue Jul 05, 2016 4:08 pm


New member

Posts

Joined
Fri Jun 14, 2013 8:33 pm

Post by imdevlper18 » Tue Jul 05, 2016 4:50 pm

This is working. when i click remove , it says loading... and then refresh happens and new cart products are shown.

Opencart Extensions | Professional opencart support | Support Ticket | support@cartbinder.com


User avatar
Active Member

Posts

Joined
Sun May 11, 2014 2:04 pm


Post by santura » Tue Jul 05, 2016 5:08 pm

Were you on the contact or home page when you emptied the cart? That's where it doesn't work for me.

New member

Posts

Joined
Fri Jun 14, 2013 8:33 pm

Post by imdevlper18 » Tue Jul 05, 2016 5:15 pm

There seems to be an extra extension on your site. Which takes to checkout page when added to cart. May be this is doing some thing. try disabling it and then click refresh icon on extension - modification page.

Opencart Extensions | Professional opencart support | Support Ticket | support@cartbinder.com


User avatar
Active Member

Posts

Joined
Sun May 11, 2014 2:04 pm


Post by santura » Tue Jul 05, 2016 5:21 pm

You could be right- the extension takes you to the cart when you add an item, and I noticed it was throwing an error which I couldn't read quick enough before the redirect.

Will disable and see what happens.

New member

Posts

Joined
Fri Jun 14, 2013 8:33 pm

Post by santura » Tue Jul 05, 2016 5:28 pm

I did that and it didn't help ... and now the cart button doesn't update when I add an item to the cart either.

New member

Posts

Joined
Fri Jun 14, 2013 8:33 pm

Post by imdevlper18 » Tue Jul 05, 2016 5:30 pm

Ohh you can enable it back. Anyways you can contact on support@cartbinder.com
We will check it.

Opencart Extensions | Professional opencart support | Support Ticket | support@cartbinder.com


User avatar
Active Member

Posts

Joined
Sun May 11, 2014 2:04 pm


Post by imdevlper18 » Tue Jul 05, 2016 5:50 pm

This is actually opencart default behavior. It will only refresh when on shopping cart or checkout page.

Opencart Extensions | Professional opencart support | Support Ticket | support@cartbinder.com


User avatar
Active Member

Posts

Joined
Sun May 11, 2014 2:04 pm

Who is online

Users browsing this forum: No registered users and 30 guests