Post by Skawty » Thu Dec 17, 2015 6:32 pm

Im using the latest version on OpenCart 2.1.0.1 with the latest Journal theme version.

my problem is that when i set my global background to a image or a color it doesent change it there is some sort of conflict with the file no_image.png and if i remove the no_image.png then there is a code error in the heading

This is the error in the heading:
Image

this is the lines its reffering to in the .php file

Code: Select all

 public static function resizeImage($tool, $image, $width = '', $height = '', $resize_type = '') {
        if (is_array($image)) {
            $image = self::getProperty($image, 'image', 'no_image.jpg');
        }
        if (!$image || !file_exists(DIR_IMAGE . $image) || !is_file(DIR_IMAGE . $image)) {
            $image = Front::$IS_OC2 ? 'no_image.png' : 'no_image.jpg';
        }
        list($width_orig, $height_orig) = getimagesize(DIR_IMAGE . $image);
        if (!is_numeric($width)) {
            $width = $width_orig;

Any help on this would be greatly appreciated

Kind Regards
Skawty

User avatar
New member

Posts

Joined
Thu Nov 26, 2015 5:31 pm
Location - UK

Post by tdaubs » Fri Dec 18, 2015 9:04 am

I'm assuming you're changing the background within the Journal theme control panel itself. If so, you probably had an issue while uploading the theme. The background functionality works fine in Journal and there are no issues with either choosing the background color or using an image.

However, since this is totally theme related... the best place to get help is from the actual Journal team. Why not submit a help ticket to them directly and they should be able to address your needs within a day.

Image
Opencart Support . Opencart Galaxy . Buy Me a Coffee?


User avatar
Active Member

Posts

Joined
Fri Apr 08, 2011 4:51 am
Location - Southern California

Post by Skawty » Fri Dec 18, 2015 6:27 pm

tdaubs wrote:I'm assuming you're changing the background within the Journal theme control panel itself. If so, you probably had an issue while uploading the theme. The background functionality works fine in Journal and there are no issues with either choosing the background color or using an image.

However, since this is totally theme related... the best place to get help is from the actual Journal team. Why not submit a help ticket to them directly and they should be able to address your needs within a day.
Thanks for your reply i will try that.

User avatar
New member

Posts

Joined
Thu Nov 26, 2015 5:31 pm
Location - UK

Post by mozeruk » Sun Oct 02, 2016 4:15 pm

Hey Skawty,

Did you get to the bottom of this? Im having the exact issue!

Thanks

Newbie

Posts

Joined
Fri Sep 19, 2014 7:52 pm

Post by tdaubs » Tue Oct 04, 2016 12:57 am

mozeruk wrote:Hey Skawty,

Did you get to the bottom of this? Im having the exact issue!

Thanks
If you reach out to Journal support, they will help you usually within 24 hours. It's the best place to get the solution as this issue is totally related to the Journal theme and not Opencart.

Image
Opencart Support . Opencart Galaxy . Buy Me a Coffee?


User avatar
Active Member

Posts

Joined
Fri Apr 08, 2011 4:51 am
Location - Southern California

Post by mozeruk » Tue Oct 04, 2016 5:55 pm

Anybody else having this issue, here is the fix...
Hi, that is an empty Fullscreen Slider.
You can edit or remove it from Journal > Fullscreen Slider.

Newbie

Posts

Joined
Fri Sep 19, 2014 7:52 pm
Who is online

Users browsing this forum: No registered users and 14 guests