Page 1 of 1

[ERROR] 500 Internal Server Error - Cannot allocate memory

Posted: Sun Sep 06, 2015 1:29 am
by comitstore
Excuse me, I want to ask, in OpenCart I like appearing popup error "500 internal server error", the appearance of the contents of a form or display form (sometimes appears sometimes not) the emergence on the homepage and admin page.
Admin Panel.png

error 1 - Admin Panel.png (186.58 KiB) Viewed 1308 times

Checkout.png

error 2 - Checkout.png (227.96 KiB) Viewed 1308 times

Error.txt in cpanel:

Code: Select all

[Sat Sep 05 23:32:35 2015] [error] [client 36.75.254.155] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/rama/public_html/index.php, referer: http://www.ramakomputer.com/admin/index.php?route=setting/setting&token=8986ee8c4b4cb87e62fa5a6ba7933866
[Sat Sep 05 23:32:35 2015] [error] [client 36.75.254.155] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/rama/public_html/admin/index.php, referer: http://www.ramakomputer.com/admin/index.php?route=setting/setting&token=8986ee8c4b4cb87e62fa5a6ba7933866
[Sat Sep 05 23:29:34 2015] [error] [client 36.75.254.155] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/rama/public_html/index.php, referer: http://www.ramakomputer.com/index.php?route=checkout/checkout
[Sat Sep 05 23:29:34 2015] [error] [client 36.75.254.155] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/rama/public_html/index.php, referer: http://www.ramakomputer.com/index.php?route=checkout/checkout
.htaccess script

Code: Select all

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled. 

# 2. In your opencart directory rename htaccess.txt to .htaccess.

# For any support issues please visit: http://www.opencart.com

Options +FollowSymlinks

# Prevent Directoy listing 
# Options -Indexes

# Prevent Direct Access to files
<FilesMatch "(?i)((\.tpl|\.ini|\.log|(?<!robots)\.txt))">
 Order deny,allow
 Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
RewriteCond %{HTTP_HOST} ^ramakomputer.com [NC]
RewriteRule ^(.*)$ http://www.ramakomputer.com/$1 [L,R=301,NC]

# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/ 

RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
RewriteRule ^system/download/(.*) /index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

### Additional Settings that may need to be enabled for some servers 
### Uncomment the commands by removing the # sign in front of it.
### If you get an "Internal Server Error 500" after enabling any of the following settings, restore the # as this means your host doesn't allow that.

# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
# php_flag register_globals off

# 2. If your cart has magic quotes enabled, This may work to disable it:
# php_flag magic_quotes_gpc Off

# 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try
# php_value upload_max_filesize 999M

# 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value post_max_size 999M

# 5. set max time script can take. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_execution_time 200

# 6. set max time for input to be recieved. Uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_input_time 200

# 7. disable open_basedir limitations
# php_admin_value open_basedir none

RewriteCond %{HTTP_REFERER} !^http://ramakomputer.com/.*$      [NC]
RewriteCond %{HTTP_REFERER} !^http://ramakomputer.com$      [NC]
RewriteCond %{HTTP_REFERER} !^http://www.ramakomputer.com/.*$      [NC]
RewriteCond %{HTTP_REFERER} !^http://www.ramakomputer.com$      [NC]
RewriteRule .*\.(jpg|jpeg|gif|png|bmp)$ - [F,NC]
php.ini script

Code: Select all

magic_quotes_gpc = Off;
register_globals = Off;
default_charset	= UTF-8;
memory_limit = 256M;
max_execution_time = 36000;
upload_max_filesize = 999M;
safe_mode = Off;
mysql.connect_timeout = 20;
session.use_only_cookies = On;
session.use_trans_sid = Off;
session.cookie_httponly = On;
session.gc_maxlifetime = 172800;
allow_url_fopen = on;
;display_errors = 1;
;error_reporting = E_ALL;
please help, I've been searching on google but can not yet powerful solution. thanks before

Re: [ERROR] 500 Internal Server Error - Cannot allocate memo

Posted: Mon Sep 07, 2015 10:57 am
by comitstore
UP!! ;D

Re: [ERROR] 500 Internal Server Error - Cannot allocate memo

Posted: Fri Dec 09, 2016 5:36 pm
by zjasper
Same problem for me. Nowhere on the internet is a solution for this.

Re: [ERROR] 500 Internal Server Error - Cannot allocate memo

Posted: Fri Dec 09, 2016 9:19 pm
by thekrotek
Most likely, this is server related issue. I'd suggest you to contact your hosting provider on the matter.

Re: [ERROR] 500 Internal Server Error - Cannot allocate memo

Posted: Sun Dec 18, 2016 6:10 pm
by chialiyen
Hi, have you managed to solve this issue?
I'm seeing the same error on my end too :(

Re: [ERROR] 500 Internal Server Error - Cannot allocate memory

Posted: Fri Jan 12, 2018 6:10 pm
by vtechgt
Solved. I just talked to my hosting company. the follow reply from him.

We checked the error log on your cpanel and see the problem are due to Cannot allocate memory.
We special increased the virtual memory for you, if you need more resource usage, please consider upgrade your plan.

ask hosting company to increased the virtual memory for you. everything alright now.

;D ;D