Post by tjvisualdesign » Thu Sep 03, 2015 10:28 am

Hi, I'm having a strange problem were my products are not showing up in the products area. I've been using a free import/export extension to import my products and it was going pretty well, with it throwing some errors when uploading products, but it usually fixed itself when I refreshed the page or just pressed enter on the search bar path, taking me back to the extension with the success message there.

I've had a look at my database and it looks fine with all the products showing up and even the site shows the products, but the products area in the backend doesn't? When I search for a product the products area it will find it and when I filter for that product then it will show up and I'll be able to edit it.

I'm importing 2000 products at a time with a total of 93000 products, but have only imported 8000 as I want to fix this problem before continuing.

I'm using 2.0.1.1

Any help would be greatly appreciated.

New member

Posts

Joined
Tue Jul 14, 2015 10:02 am

Post by dolrichfortich » Thu Sep 03, 2015 6:01 pm

Try clearing your cache. Its on system/cache/

Opencart Options Pro, Reward Points For Review, DISQUS Comment Form,
Dolrich Fortich - Freelance web developer

Image


User avatar
New member

Posts

Joined
Thu Aug 05, 2010 8:09 pm
Location - Philippines

Post by tjvisualdesign » Fri Sep 04, 2015 8:04 am

Yeah I tried that but not luck...

Error log looks like this when I try to upload anymore products:

2015-09-03 17:54:59 - PHP Notice: Error: Got error 28 from storage engine<br />Error No: 1030<br />SHOW COLUMNS FROM `oc_product_image` LIKE 'sort_order' in /home/system/library/db/mysqli.php on line 40

2015-09-03 17:54:59 - PHP Notice: Trying to get property of non-object in /home/admin/model/tool/export_import.php on line 2685

2015-09-03 17:54:59 - PHP Warning: fread(): Length parameter must be greater than 0 in /home/system/PHPExcel/Classes/PHPExcel/CachedObjectStorage/PHPTemp.php on line 118

2015-09-03 17:54:59 - PHP Fatal Error: Call to a member function attach() on a non-object in /home/system/PHPExcel/Classes/PHPExcel/CachedObjectStorage/PHPTemp.php on line 120

2015-09-03 17:54:59 - PHP Warning: Cannot modify header information - headers already sent by (output started at /home/system/PHPExcel/Classes/PHPExcel/CachedObjectStorage/PHPTemp.php:120) in /home/admin/model/tool/export_import.php on line 49

2015-09-03 17:54:59 - PHP Warning: Cannot modify header information - headers already sent by (output started at /home/system/PHPExcel/Classes/PHPExcel/CachedObjectStorage/PHPTemp.php:120) in /home/admin/model/tool/export_import.php on line 50

Any thoughts?

Maybe I should try and clear the database of all products and start again, is there an easy way to do that?

New member

Posts

Joined
Tue Jul 14, 2015 10:02 am

Post by tjvisualdesign » Fri Sep 04, 2015 8:27 am

Disregard that last error log I found an error in the excel sheet that I think was causing it. It's uploading fine now, but still no products showing up in the product area.

Some other things you might want to know is that I was using a option in the importer called phpTemp cache for large Imports.

It was throwing an error when I had that selected so I unselected it and it's working now. So maybe it had something to do with it?

New member

Posts

Joined
Tue Jul 14, 2015 10:02 am

Post by ArcherData » Fri Sep 04, 2015 10:05 pm

On advice of the plugin author, I edited and saved the spreadsheet in Open Office ODS format and it imported flawlessly.

Don Bledsoe


User avatar
New member

Posts

Joined
Mon Dec 24, 2012 4:30 am
Location - Cherryvale, KS
Who is online

Users browsing this forum: No registered users and 67 guests