Post by retailbuzzard » Mon Oct 08, 2012 9:05 pm

I'm trying to restore my store and I keep getting "Warning: The file you uploaded was empty!" when I try to upload the backup.sql file. I made a backup of the current store and uploaded that sql file and it worked but the older backup files (which actually have my products) don't work.

Newbie

Posts

Joined
Thu Apr 26, 2012 12:28 pm

Post by merry » Thu Oct 18, 2012 1:10 am

retailbuzzard wrote:I'm trying to restore my store and I keep getting "Warning: The file you uploaded was empty!" when I try to upload the backup.sql file. I made a backup of the current store and uploaded that sql file and it worked but the older backup files (which actually have my products) don't work.
Retail Buzzard,

Have you resolved this problem yet? Please let us know. If not, it sounds to me like you may have a permissions problem that is preventing you from uploading the file.

Merry

Most answers are from my OpenCart 1.5 User Manual CURRENT TO 1.5.5.1 and includes free updates.
FREE HELP! 60-page user guide with OpenCart Admin Menu Cheatsheet, Install Guide & 30 Minute QuickStart Guide: http://showmeguides.com/


User avatar
Active Member

Posts

Joined
Thu Dec 09, 2010 12:51 am
Location - Mexico and sometimes Texas

Post by Джек » Sat Nov 03, 2012 4:55 pm

Hello there guys, I'm new to opencart, and have the same problem.
I have installed a new opencart 1.5.4.1 and made a backup from the other opencart and restored with it with fresh install.

Anyone have an idea what it could be?

Many thanks

Newbie

Posts

Joined
Sat Nov 03, 2012 4:50 pm

Post by Platoxia » Sun Dec 09, 2012 9:30 pm

I am also having this error when I try to restore the database.

I am using OC 1.5.3.1.

Fortunately, I can do backups and restores through phpmyadmin, but I really would love it if my site was working properly. I'm affraid it may point to a larger issue and, if so, I don't know what else could go wrong.

All of my google searches for this issue come up empty...no solution to this problem is posted anywhere.

Newbie

Posts

Joined
Fri Apr 27, 2012 7:46 am

Post by retrocanyon » Mon Jan 21, 2013 10:50 pm

You can try increasing your memory_limit in admin/php.ini file and try to restore the backup file again. If memory_limit=64M try increasing it to memory_limit=256M

If that doesn't work, you should try to restore the backup file from phpmyadmin: open phpmyadmin, select your opencart database, click on the Import tab, select the backup file and press GO. It is recommended that you backup before you do this as well.

This information was given to me by a friend, and has helped me restore when I need it. I have not figured out how to exactly fix the opencart interface problem.

I hope this can help you.

Ashleigh :)

Newbie

Posts

Joined
Tue Nov 27, 2012 9:58 pm

Post by emilioj » Wed Feb 27, 2013 7:43 pm

Hi!

Did you try to increase the maximum allowed size for uploaded files in php.ini (globally, eg. in /etc/php5/apache2/php.ini).

I was having this problem and I fixed this way:

; Maximum allowed size for uploaded files.
; http://php.net/upload-max-filesize
upload_max_filesize = 5M

Newbie

Posts

Joined
Fri Jan 27, 2012 5:21 pm

Post by neeticollections » Sun Jul 30, 2017 1:28 am

Hi All,
You should open the .htaccess and see the solution for yourself - Just uncomment below lines and you should be good to go.

# 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try
php_value upload_max_filesize 999M

# 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
php_value post_max_size 999M


Posts

Joined
Tue Apr 04, 2017 9:32 pm

Post by MrPhil » Sun Jul 30, 2017 2:23 am

Be aware that many systems now prohibit php_value and php_flag commands in .htaccess. You should be using, if possible, php.ini (or equivalent) and making your settings in there.

Active Member

Posts

Joined
Wed May 10, 2017 11:52 pm
Who is online

Users browsing this forum: No registered users and 12 guests