Post by Vectra » Thu May 17, 2012 8:52 am

Fresh v1.5.2.1, My host says "The Apache module "mod-rewrite" is currently installed and enabled on all of our servers by default". I changed at /public_html/store/ the file name to .htaccess (and ".htaccess." , I am not sure which is correct). I set in admin/store/settings/server to Yes for "Use SEO Urls".
The result is good URLs for products and categories, but only the "home" page shows up/loads as mysite/com/store/. The other pages give:
Not Found
The requested URL /store/VX18-home-gym was not found on this server.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

I am clearing browsing data after changes. Some times I get the similar 404 not found result, but it says it can't find "URL/index.php on this server" instead, which is also in /public_html/store/ (same folder as the .htaccess file) (this happens if I name the file ".htaccess" ).

What should I try next. None of the 6 commented commands in the htaccess file seem like they will help if I uncomment them.

Thank you
Last edited by Vectra on Thu May 17, 2012 10:36 am, edited 1 time in total.

Newbie

Posts

Joined
Sat May 12, 2012 3:32 am

User avatar
Newbie

Posts

Joined
Wed Nov 16, 2011 11:53 am
Location - Singapore

Post by Vectra » Thu May 17, 2012 10:30 am

Thank you for the reply. I went to the htaccess file at /public_html/store/ (Itried both .htaccess. and .htaccess as file names) and I got the same result (404 not found) after I changed this section to:

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

RewriteBase /shop/
RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

This is the full result:
Not Found
The requested URL /store/home-gyms was not found on this server.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

I cleared the web browsing/cache/cookies data. I thank you for your reply, but I haven't quite got it yet. What do you think?
Thank you.

Newbie

Posts

Joined
Sat May 12, 2012 3:32 am

Post by Vectra » Thu May 17, 2012 10:35 am

Oops. I fixed my problem.
I changed to "store" instead of "shop". That was dumb.
It works now with ".htaccess" as the file name.
Thank you.

Newbie

Posts

Joined
Sat May 12, 2012 3:32 am

Post by ranu70 » Tue Mar 28, 2017 7:19 pm

Hi Sir I am also getting the same problem home page is loading fine but rest of pages gives the same error

"Not Found
The requested URL /9-axis-magnetic-acceleration-gyro-module-GY80 was not found on this server.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

My .htaccess file is
-------------------------------------------------------------------------------------------------------------------------
# 1.To use URL Alias you need to be running apache with mod_rewrite enabled.

# 2. In your opencart directory rename htaccess.txt to .htaccess.

# For any support issues please visit: http://www.opencart.com

Options +FollowSymlinks

# Prevent Directoy listing
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "\.(tpl|ini|log)">
Order deny,allow
Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

### Additional Settings that may need to be enabled for some servers
### Uncomment the commands by removing the # sign in front of it.
### If you get an "Internal Server Error 500" after enabling any of the following settings, restore the # as this means your host doesn't allow that.

# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
# php_flag register_globals off

# 2. If your cart has magic quotes enabled, This may work to disable it:
# php_flag magic_quotes_gpc Off

# 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try
# php_value upload_max_filesize 999M

# 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value post_max_size 999M

# 5. set max time script can take. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_execution_time 200

# 6. set max time for input to be recieved. Uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_input_time 200

# 7. disable open_basedir limitations
# php_admin_value open_basedir none
--------------------------------------------------------------------------------------------------------------------------
I did the modification as you suggested in above posts but still i am getting same error
I am sharing the whole path of my files on server, It will help you to find where i am getting wrong
screen.
Thanking you so much, I hope you will reply soon

Attachments

path.png

path of the files - path.png (75.36 KiB) Viewed 860 times


Newbie

Posts

Joined
Tue Apr 01, 2014 12:31 pm

Post by MarketInSG » Mon Apr 03, 2017 6:36 am

you are missing the dot at the front of the file name. It needs to be .htaccess and not htaccess.


User avatar
Newbie

Posts

Joined
Wed Nov 16, 2011 11:53 am
Location - Singapore

Post by ranu70 » Mon Apr 03, 2017 1:19 pm

Thank you so much sir

Newbie

Posts

Joined
Tue Apr 01, 2014 12:31 pm
Who is online

Users browsing this forum: Boppe and 16 guests