Post by platypuspuzzles » Sun May 13, 2012 6:22 pm

Hi all
I've upgraded to 1.5.2.2patch and as I can't get my options working (used to have GMO installed), I tried upgrading vQmod, however I now have the following error:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@namepuzz.platypuspuzzles.com.au and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

Apache/2.2.22 (Unix) mod_ssl/2.2.22 OpenSSL/0.9.8e-fips-rhel5 DAV/2 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at namepuzzles.com.au Port 80

Im now restoring my website, but I am at a loss as to how to get my options working again.

Can someone please help me???

Active Member

Posts

Joined
Sun Jan 23, 2011 8:11 pm

Post by anung » Mon May 14, 2012 12:19 am

I get the same thing, and the solutions that I do is, change. htaccess to htaccess.txt, but this will affect the SEO,
hopefully help.

Highly recommended!
OpencartNews - OpenCart News, Tutorial and Tips
Opencart Blog Manager
Opencart 2.x Blog Manager 2
Opencart Customer Summary
Default2 - Free Opencart 2.x Themes


User avatar
Active Member

Posts

Joined
Fri Mar 30, 2012 10:32 am
Location - Indonesia

Post by platypuspuzzles » Mon May 14, 2012 7:26 am

Ahh, see that wont work for me, as I need the SEO to work.

I've restored my website now, and will just leave vQmod off until there are other suggestions on how to make it work with both vQmod and SEO.

Thanks though for answering

Active Member

Posts

Joined
Sun Jan 23, 2011 8:11 pm

Post by qahar » Mon May 14, 2012 7:18 pm

No need to rename / remove .htaccess on root. Just remove the .htaccess file in the vqmod/ folder and it should work fine.

My product: Customer Summary | Blog Manager 2 | default2 - free OpenCart Theme

OpencartNews - News, Tutorial n Tips - Common OpenCart Errors and How to Solve Them
Tips for Requesting Support | Update op thread title w/ [SOLVED] for solved issue.


User avatar
Expert Member

Posts

Joined
Tue Jun 29, 2010 10:24 pm
Location - Indonesia

Post by nyomanmusdina » Sun Oct 07, 2012 9:36 am

Hi Qahar,

I'm experiencing the same thing...then I removed the .htaccess file in the vqmod/ folder
but still not working,,still error.

Please help mate

Thanks

Nyoman BGC
Your Balinese Fellow
http://www.baligoodjewelry.com


User avatar
New member

Posts

Joined
Fri Sep 02, 2011 9:06 am
Location - Bali, Indonesia

Post by platypuspuzzles » Tue Oct 09, 2012 9:49 pm

It's me again!

The above suggestion worked last time, but now that i've upgraded to 2.1.7 just after upgrading to oc1.5.4.1, I have the error 500 appear straight after running the script via domain.com/vqmod/install/

Is there any other suggestion please?

Active Member

Posts

Joined
Sun Jan 23, 2011 8:11 pm

Post by kattydown » Thu Oct 11, 2012 12:02 pm

Do we have any answers if removing the .htaccess from /vqmod has no effect?

Newbie

Posts

Joined
Thu Oct 11, 2012 12:00 pm

Post by platypuspuzzles » Thu Oct 18, 2012 9:59 am

I haven't received any support for this, sorry.

The only way I could fix it was to reinstall 1.5.3.1, then upgrade to 1.5.4.1 until it worked.

To save time, I created a duplicate of my website on my host space, and when it didn't work, I would delete the website, and copy the backup across to my public_html folder - was MUCH faster than re-uploading my backup file.

Not sure if this is safe, but it literally saved me days.

Active Member

Posts

Joined
Sun Jan 23, 2011 8:11 pm

Post by rijalul » Thu Jan 17, 2013 11:30 am

Just try changing file & folder permissions 755 or 777.
In my case, after got Error 500, than I try changing file permission of index.php, admin folder, admin/index.php, vqmod folder, vqmod/index.php, vqmod/vqcache folder, to 755. It works. Don't have to change .htaccsess!

Newbie

Posts

Joined
Wed May 02, 2012 3:03 pm

Post by MODAYBELLEZA » Mon Jun 24, 2013 6:52 pm

Thanks so much!!
i was having the internal Error 500

Re: vQmod upgrade internal Error 500
by qahar » Mon May 14, 2012 11:18 am

No need to rename / remove .htaccess on root. Just remove the .htaccess file in the vqmod/ folder and it should work fine.

I just erase the .htaccess on root. Just remove the .htaccess file in the vqmod/ folder and now is installed!!

Español:
Para el error de servidor 500 después de tratar de activar el vqmod, a mi me funciono el borra el archivo .htaccess de la carpeta de vqmod, ahora esta correctamente instalado.

Newbie

Posts

Joined
Mon Jun 24, 2013 6:48 pm

Post by Kingnamo » Mon Sep 09, 2013 5:56 pm

Just set the File Permission of index.php files located at the root and at the admin folder to 755 and you will be fine. O0

Newbie

Posts

Joined
Mon Sep 09, 2013 5:55 pm

Post by essexboyupnorth » Sat Oct 05, 2013 9:03 pm

Yep, changing the permissions of the index.php file to 755 worked for me, you can leave the .htaccess files where they are.


Posts

Joined
Sat Mar 09, 2013 6:33 am

Post by DigitalArena » Sun Apr 19, 2015 4:40 am

I have tried all of these solutions to no avail. I've done the chmod 755, I've checked the configs, I've renamed the .htaccess. Since installing vQmod all my site pages are blank. I've even done a fresh install on a new domain, and I still get the same problem. Is there some prerequisite to vQmod I am not aware of. I just don't understand how I can follow the instructions, do what everyone else is doing and it not work.

Newbie

Posts

Joined
Sun Apr 19, 2015 12:19 am

Post by widekart » Tue Sep 01, 2015 10:55 am

You shoul change file permission 755, it will work,

Newbie

Posts

Joined
Tue Sep 01, 2015 10:53 am

Post by TROLL » Fri Mar 24, 2017 2:07 am

I'm getting an error trying to install this as well.
Opencart 1.5.6.4
I tried changing file permissions to 755 on index.php in vqmod/install to 755 but still get an error. Then I also changed the permissions to 755 on index.php in the admin folder and still get the same error. (Also, what read/write permissions should these files be set to long term? They were at 644 previously.)

I type in http://flashgels.com/vqmod/install/ to my browser and it auto redirects (via .htaccess which is how I have the site set up) to https://flashgels.com/vqmod/install/
I get this error notice when the page loads:

"Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@flashgels.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

I'm not sure where to go from here -- can anyone help? Thanks!

Newbie

Posts

Joined
Sat Mar 18, 2017 9:51 pm

Post by IP_CAM » Fri Mar 24, 2017 7:48 am

404 Not Found means, that some file does not exist.
But VqMod exists in two Forms, one for OpenCart, and a stand-alone Edition for other Software.
If you don't find an INDEX.PHP file in your vqmod/install/... Subdirectory, then,
you just installed the wrong VqMod, and it does not work. I had the same problem, a while ago... ;)

Check on github first, wich 2.6.1 Version includes this vqmod/install/INDEX.PHP file,
I found it in the MASTER Branch, when downloading the official OC 2.6.1 version first, it was
NOT part of it either.... :-\ :-\ :-\
https://github.com/vqmod/vqmod/tree/ope ... od/install
Good Luck!
Ernie

Ernie's OpenShop 1.75 with responsive Bootstrap Themes:
http://www.bigmax.ch - http://www.ocshop.li
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by TROLL » Fri Mar 24, 2017 8:01 am

Thank you for the response, unfortunately I don't think this is the problem.

I do have index.php in my install directory.

There's got to be something else I'm missing...

Newbie

Posts

Joined
Sat Mar 18, 2017 9:51 pm

Post by TROLL » Wed Mar 29, 2017 3:37 am

bumping this in case any other geniuses see this and can help. I'd really like to get a cheaper international shipping option added to my site by way of flat rate mail and I need VQ Mod to get there!

Newbie

Posts

Joined
Sat Mar 18, 2017 9:51 pm
Who is online

Users browsing this forum: No registered users and 31 guests