Page 4 of 21

Re: [BETA3] Upgrade Script 14x to 1.5.1.2 PLUS PRODUCT OPTIO

Posted: Fri Feb 10, 2012 2:21 am
by Oneilus
When upgrading with this script, does it also save the customer base and the orders?

Re: [BETA3] Upgrade Script 14x to 1.5.1.2 PLUS PRODUCT OPTIO

Posted: Fri Feb 10, 2012 5:01 am
by Qphoria
Oneilus wrote:When upgrading with this script, does it also save the customer base and the orders?
Yes, as the first post states

Re: [BETA3] Upgrade Script 14x to 1.5.1.2 PLUS PRODUCT OPTIO

Posted: Sun Feb 12, 2012 6:28 pm
by dule
Hello
I made upgrade1.4.4 - 1.5.1.3) following the instructions, but I have a problem, when I open http://mojag.ias3.com/index.php/index.p ... ommon/home is everything OK, but when I click on any link the site is empty (Category not found!, ....)
I do not know what to do
please help

Thank you

Re: [BETA3] Upgrade Script 14x to 1.5.1.2 PLUS PRODUCT OPTIO

Posted: Mon Feb 13, 2012 12:28 am
by Qphoria
dule wrote:Hello
I made upgrade1.4.4 - 1.5.1.3) following the instructions, but I have a problem, when I open http://mojag.ias3.com/index.php/index.p ... ommon/home is everything OK, but when I click on any link the site is empty (Category not found!, ....)
I do not know what to do
please help

Thank you
But that isn't an upgraded site. that is a new install with all the default opencart products

Re: [BETA3] Upgrade Script 14x to 1.5.1.2 PLUS PRODUCT OPTIO

Posted: Wed Feb 15, 2012 11:42 pm
by TLone
Upgraded. Everything seemed to go smoothly all though I did not select "http" instead had "https", so went back and edited all instance of https in index. to http.... that seemed to solve that.

So, looking good... all though I"m not sure how to get my products back up yet :)

But, when trying to edit Cart in Modules I get:
Fatal error: Cannot access private property Document::$title in /home/troutleg/public_html/store/admin/controller/module/cart.php on line 8

Re: [BETA3] Upgrade Script 14x to 1.5.1.2 PLUS PRODUCT OPTIO

Posted: Thu Feb 16, 2012 1:05 am
by Qphoria
TLone wrote:But, when trying to edit Cart in Modules I get:
Fatal error: Cannot access private property Document::$title in /home/troutleg/public_html/store/admin/controller/module/cart.php on line 8
Best to read my smart-alecky post here:
http://forum.opencart.com/viewtopic.php ... 40#p248895

Re: [BETA3] Upgrade Script 14x to 1.5.1.2 PLUS PRODUCT OPTIO

Posted: Sun Feb 19, 2012 7:07 pm
by sbproduction
Not sure what happened upgraded and did what the intructions said and it asked me to enter all the database information and now it looks like a new store and has lost all my information. What exactly am i doing wrong as its really not hard to follow the simple instructions but somewhere along the way its not working. www.livelifesports.co.uk

Re: [BETA3] Upgrade Script 14x to 1.5.1.2 PLUS PRODUCT OPTIO

Posted: Mon Feb 20, 2012 6:36 am
by Qphoria
sbproduction wrote:Not sure what happened upgraded and did what the intructions said and it asked me to enter all the database information and now it looks like a new store and has lost all my information. What exactly am i doing wrong as its really not hard to follow the simple instructions but somewhere along the way its not working. http://www.livelifesports.co.uk
You overwrote your config.php or admin/config.php file most likely.

Re: [BETA3] Upgrade Script 14x to 1.5.1.2 PLUS PRODUCT OPTIO

Posted: Mon Feb 20, 2012 11:34 pm
by MattW
Finally upgraded from 1.4.9.6 to 1.5.1.2 (and then to 1.5.1.3).

Script works perfectly, and no problems encountered.

Re: [BETA3] Upgrade Script 14x to 1.5.1.2 PLUS PRODUCT OPTIO

Posted: Tue Feb 21, 2012 7:44 am
by Qphoria
MattW wrote:Finally upgraded from 1.4.9.6 to 1.5.1.2 (and then to 1.5.1.3).

Script works perfectly, and no problems encountered.
I'm betting that when you try to add an option you will get an error.
You will need to run this:
http://forum.opencart.com/viewtopic.php ... 92#p240257

I will be adding that into the script when I get a chance

Re: [BETA3] Upgrade Script 14x to 1.5.1.2 PLUS PRODUCT OPTIO

Posted: Tue Feb 21, 2012 9:17 am
by waabay
Awesome work Q ! I just successfully upgrade it from v1.4.9.3 to v1.5.1.3. Work Great !

Re: [BETA3] Upgrade Script 14x to 1.5.1.2 PLUS PRODUCT OPTIO

Posted: Wed Feb 22, 2012 11:25 pm
by MattW
Qphoria wrote:
MattW wrote:Finally upgraded from 1.4.9.6 to 1.5.1.2 (and then to 1.5.1.3).

Script works perfectly, and no problems encountered.
I'm betting that when you try to add an option you will get an error.
You will need to run this:
http://forum.opencart.com/viewtopic.php ... 92#p240257

I will be adding that into the script when I get a chance
Actually, I didn't encounter this when I added an option this morning
option.png

option.png (35.1 KiB) Viewed 9000 times

and working against the product
option2.png

option2.png (77.16 KiB) Viewed 9000 times


Re: [BETA3] Upgrade Script 14x to 1.5.1.2 PLUS PRODUCT OPTIO

Posted: Thu Feb 23, 2012 3:49 am
by Qphoria
weird. I think it only happens if you have existing options or something.

Re: [BETA3] Upgrade Script 14x to 1.5.1.2 PLUS PRODUCT OPTIO

Posted: Thu Mar 01, 2012 6:53 am
by iusenl
Warning: fopen(/home/xxxxxx/domains/iuse.nl/public_html/image/test) [function.fopen]: failed to open stream: Permission denied in /home/xxxxx/domains/iuse.nl/public_html/admin/controller/common/home.php on line 48Warning: fclose(): supplied argument is not a valid stream resource in /home/xxxxxx/domains/iuse.nl/public_html/admin/controller/common/home.php on line 52Warning: sprintf() [function.sprintf]: Too few arguments in /home/xxxxx/domains/iuse.nl/public_html/admin/controller/common/home.php on line 55
After updating my admin shows this error. Anyone familiar with it? I have checked those lines in my control panel but I can't seem to find the problem.. I don't know what 'fopen' stands for and where it is to find.. (no knowledge to edit either, haha)

Could anyone help me out :)?

Re: [BETA3] Upgrade Script 14x to 1.5.1.2 PLUS PRODUCT OPTIO

Posted: Fri Mar 02, 2012 5:32 am
by Qphoria
It means your /image folder isn't writable

Re: [BETA3] Upgrade Script 14x to 1.5.1.2 PLUS PRODUCT OPTIO

Posted: Fri Mar 02, 2012 8:01 pm
by iusenl
Yea, it helped! /image was 755. I thought that was writable too..indeed needed to change it to 777. Anyways, thanks a lot!

Re: [BETA3] Upgrade Script 14x to 1.5.1.2 PLUS PRODUCT OPTIO

Posted: Fri Mar 02, 2012 11:46 pm
by Qphoria
iusenl wrote:Yea, it helped! /image was 755. I thought that was writable too..indeed needed to change it to 777. Anyways, thanks a lot!
Yea unfortunately there is no global setting for permissions. Depending on how php is installed depends whether or not 755 or 777 is needed. I wonder if there is some programmatical way to determine it.

Re: [BETA3] Upgrade Script 14x to 1.5.1.2 PLUS PRODUCT OPTIO

Posted: Sat Mar 03, 2012 2:58 am
by Qphoria
Possibly 775 is the magic in between number

Re: [BETA3] Upgrade Script 14x to 1.5.1.2 PLUS PRODUCT OPTIO

Posted: Tue Mar 06, 2012 5:04 am
by melamed5
I receive this eror:
Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /home/liav/public_html/yev/upload/install/model/upgrade.php on line 63

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /home/liav/public_html/yev/upload/install/model/upgrade.php on line 63

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /home/liav/public_html/yev/upload/install/model/upgrade.php on line 63

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /home/liav/public_html/yev/upload/install/model/upgrade.php on line 63

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /home/liav/public_html/yev/upload/install/model/upgrade.php on line 63

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /home/liav/public_html/yev/upload/install/model/upgrade.php on line 63

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /home/liav/public_html/yev/upload/install/model/upgrade.php on line 54
Could not Execute: ALTER TABLE option_value ADD image varchar(255) NOT NULL COMMENT '' COLLATE utf8_bin AFTER option_id;
Table 'liav_yev.option_value' doesn't exist
What I need to do?

Re: [BETA3] Upgrade Script 14x to 1.5.1.2 PLUS PRODUCT OPTIO

Posted: Tue Mar 06, 2012 6:19 am
by Qphoria
melamed5 wrote:I receive this eror:
Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /home/liav/public_html/yev/upload/install/model/upgrade.php on line 63

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /home/liav/public_html/yev/upload/install/model/upgrade.php on line 63

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /home/liav/public_html/yev/upload/install/model/upgrade.php on line 63

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /home/liav/public_html/yev/upload/install/model/upgrade.php on line 63

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /home/liav/public_html/yev/upload/install/model/upgrade.php on line 63

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /home/liav/public_html/yev/upload/install/model/upgrade.php on line 63

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /home/liav/public_html/yev/upload/install/model/upgrade.php on line 54
Could not Execute: ALTER TABLE option_value ADD image varchar(255) NOT NULL COMMENT '' COLLATE utf8_bin AFTER option_id;
Table 'liav_yev.option_value' doesn't exist
What I need to do?
You should only get that if you ran it twice. You should be able to just ignore it and continue on with the rest of the process