Post by ocartman » Fri Aug 07, 2015 8:08 pm

Finally got it working, i would revert back after i would see the errors in this module and i assume were old modules.
I imagine i have so much old code in the directory from upgrading the software, it would be nice if this was somehow removed during the upgrade.
I did notice that my options all had doubles so i deleted one of them.

thanks for the help.

Active Member

Posts

Joined
Fri Oct 15, 2010 12:01 am

Post by Qphoria » Wed Aug 12, 2015 9:47 pm

ocartman wrote:Finally got it working, i would revert back after i would see the errors in this module and i assume were old modules.
I imagine i have so much old code in the directory from upgrading the software, it would be nice if this was somehow removed during the upgrade.
I did notice that my options all had doubles so i deleted one of them.

thanks for the help.
Yea sometimes the options are duplicated because in 1.4.x if you have
Product A
- Color : Red

and
Product B
- Color : Red

The script tries to merge the colors into the option table resulting in 2 Color: Red entries

As far as extra files, you "could" rename the admin, catalog, and system folder before uploading the new files, then copy the config.php file from the renamed admin folder to the new admin folder before continuing with the built in upgrade script that comes with the version you downloaded.

OpenCart 2.0.x Mod Update Info

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by viperarchery » Tue Oct 20, 2015 9:09 am

Ok I just did the beta upgrade and I'm getting all these errors. Can someone help me determine what I need to do? Im not sure where to go from here...
Here are the errors:
OpenCart 1.x Upgrade Script (BETA)

The following errors occured:

Could not execute this query: SELECT @dat:=`value` FROM oc_setting WHERE `group` = 'config' and `key` = 'config_description_1'; Unknown column 'group' in 'where clause'

Could not execute this query: SELECT @id:=`setting_id` FROM oc_setting WHERE `group` = 'config' and `key` = 'config_description_1'; Unknown column 'group' in 'where clause'

Could not execute this query: SELECT @dat:=`value` FROM oc_setting WHERE `group` = 'config' and `key` = 'config_welcome_1'; Unknown column 'group' in 'where clause'

Could not execute this query: INSERT INTO `oc_option` (`option_id`, `type`, `sort_order`)SELECT `product_option_id`, "select", `sort_order` FROM `oc_product_option`; Unknown column 'sort_order' in 'field list'

Could not execute this query: INSERT INTO `oc_option_description` (`option_id`, `language_id`, `name`)SELECT `product_option_id`, `language_id`, `name` FROM `oc_product_option_description`; Table 'vipera6_ocar197.oc_product_option_description' doesn't exist

Could not execute this query: INSERT INTO `oc_option_value` (`option_value_id`, `option_id`, `sort_order`)SELECT `product_option_value_id`, `product_option_id`, `sort_order` FROM `oc_product_option_value`; Unknown column 'sort_order' in 'field list'

Could not execute this query: INSERT INTO `oc_option_value_description` (`option_value_id`, `language_id`, `option_id`, `name`)SELECT `pov`.`product_option_value_id` , `language_id` , `pov`.`product_option_id` , `name`FROM `oc_product_option_value_description` AS `povd` INNER JOIN `oc_product_option_value` AS `pov` ON `pov`.`product_option_value_id` = `povd`.`product_option_value_id`; Table 'vipera6_ocar197.oc_product_option_value_description' doesn't exist

The above errors occurred because the script could not properly determine the existing state of those db elements. Your store may not need those changes. Please post any errors on the forums to ensure that they can be addressed in future versions!

Newbie

Posts

Joined
Thu Sep 10, 2015 8:06 pm

Post by mighty9403 » Sat Apr 08, 2017 12:52 am

I'm looking to upgrade my current version of Opencart from 1.5.4.6 to version 2 is this the correct tutorial to follow?

New member

Posts

Joined
Tue Aug 28, 2012 4:28 pm

Post by IP_CAM » Sun Apr 09, 2017 1:43 am

not really, but you'll find huge amounts of information on this, if you search this Place by use of Google.
And in any case, you better remove everything on Themes and/or Extensions/VqMods first, and get
your place down to default Values, before even trying. Then, create another Shop and DB, to test it out.
And don't touch your running Place, before everything is tested and works, or you have a good chance
to end up in plain frustration, and no more running Shop.

Still, a version v.1.5.4.6 did not exist, as I recall... :o
Ernie

Ernie's OpenShop v.1.75 + OpenCart v.1.5.6.5 LIGHT Test Sites with free responsive Themes
http://www.bigmax.ch/shop/ - http://www.ebikes.li - http://www.ipc.li/shop/ - http://www.openshop.li/shop/
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by EvolveWebHosting » Sun Apr 09, 2017 4:16 am

IP_CAM wrote:
Sun Apr 09, 2017 1:43 am


Still, a version v.1.5.4.6 did not exist, as I recall... :o
Ernie
1.5.4.6 did not exist but 1.5.6.4 was a released version.

Image
https://www.evolvewebhost.com
Unhappy with your current host? We can migrate your account today (usually for no fee)! Visit our website and signup and we'll take care of the rest!
24/7/365 support
Image


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA

Post by IP_CAM » Sun Apr 09, 2017 5:34 am

oops, sorry, I forgot :laugh:

Ernie's OpenShop v.1.75 + OpenCart v.1.5.6.5 LIGHT Test Sites with free responsive Themes
http://www.bigmax.ch/shop/ - http://www.ebikes.li - http://www.ipc.li/shop/ - http://www.openshop.li/shop/
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by Carsten » Sun Apr 23, 2017 12:34 am

Hello.
After upgrading, after step 12, I get the following error.
Any advice?

Fatal error: Uncaught exception 'Exception' with message 'Error: Could not load model total!' in /home2/cnielsen/public_html/new-beat.net/shop/system/engine/loader.php:169 Stack trace: #0 [internal function]: Loader->{closure}(Array, Array) #1 /home2/cnielsen/public_html/new-beat.net/shop/system/engine/proxy.php(25): call_user_func_array(Object(Closure), Array) #2 /home2/cnielsen/public_html/new-beat.net/shop/catalog/controller/common/cart.php(37): Proxy->__call('getTotal', Array) #3 /home2/cnielsen/public_html/new-beat.net/shop/catalog/controller/common/cart.php(37): Proxy->getTotal(Array) #4 [internal function]: ControllerCommonCart->index(Array) #5 /home2/cnielsen/public_html/new-beat.net/shop/system/engine/action.php(51): call_user_func_array(Array, Array) #6 /home2/cnielsen/public_html/new-beat.net/shop/system/engine/loader.php(24): Action->execute(Object(Registry), Array) #7 /home2/cnielsen/public_html/new-beat.net/shop/catalog/controller/common/header.php(129): Loader->controller('common/cart') #8 [internal functio in /home2/cnielsen/public_html/new-beat.net/shop/system/engine/loader.php on line 169

Newbie

Posts

Joined
Sun Apr 23, 2017 12:32 am
Who is online

Users browsing this forum: No registered users and 40 guests