Post by Ozfarmer » Fri Oct 07, 2011 9:35 am

I cannot work out whats causing this

2011-10-07 12:31:25 - PHP Warning: session_start() [<a href='function.session-start'>function.session-start</a>]: The session id is too long or contains illegal characters, valid characters are a-z, A-Z, 0-9 and '-,' in /home/xxxxxxxxx/public_html/system/library/session.php on line 11

getting 100's /day in the error log.

What would this relate to?

Active Member

Posts

Joined
Wed Aug 17, 2011 7:08 pm
Location - Australia

Post by Ozfarmer » Thu Oct 13, 2011 6:42 am

No one has any ideas?

Active Member

Posts

Joined
Wed Aug 17, 2011 7:08 pm
Location - Australia

Post by uksitebuilder » Thu Oct 13, 2011 6:04 pm

Please try adding the following to your php.ini in your root and admin folder

Code: Select all

session.auto_start = 0;
or

Code: Select all

session.auto_start = Off;

ImageImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by Ozfarmer » Fri Oct 14, 2011 7:59 am

Hey Simon, thanks for repling tried both options and unfortunately they didnt work :'( still getting:
2011-10-14 10:55:54 - PHP Warning: session_start() [<a href='function.session-start'>function.session-start</a>]: The session id is too long or contains illegal characters, valid characters are a-z, A-Z, 0-9 and '-,' in /home/xxxxxxxx/public_html/system/library/session.php on line 11

Php.ini is:

magic_quotes_gpc = Off;
register_globals = Off;
default_charset = UTF-8;
memory_limit = 64M;
max_execution_time = 18000;
upload_max_filesize = 999M;
safe_mode = Off;
mysql.connect_timeout = 20;
session.auto_start = Off;
session.use_cookies = On;
session.use_trans_sid = Off;
session.gc_maxlifetime = 12000000;
allow_url_fopen = on;

Active Member

Posts

Joined
Wed Aug 17, 2011 7:08 pm
Location - Australia

Post by uksitebuilder » Fri Oct 14, 2011 4:15 pm

Hi

Not sure what version of OC you are using, but try the following:

open: system/library/session.php

find

Code: Select all

session_start();
change to

Code: Select all

$ok = @session_start();
if(!$ok){
   session_regenerate_id(true); // replace the Session ID
   session_start(); // restart the session (since previous start failed)
}
open: system/startup.php

find

Code: Select all

sesson_start();
change to

Code: Select all

$ok = @session_start();
if(!$ok){
   session_regenerate_id(true); // replace the Session ID
   session_start(); // restart the session (since previous start failed)
}

ImageImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by Ozfarmer » Fri Oct 14, 2011 5:11 pm

Thanks Simon, no still the same.. Whats the easiest procedure to re-install OC?

Active Member

Posts

Joined
Wed Aug 17, 2011 7:08 pm
Location - Australia

Post by uksitebuilder » Fri Oct 14, 2011 6:04 pm

Upload all the default files apart from config.php and admin/config.php

I think though it is a server configuration that is causing your problem

A search on google for your error message reveals several results

ImageImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by goozluk » Wed Apr 02, 2014 4:40 pm

Before doing all modifications, try to erase all cookies of your website. it worked for me.

Newbie

Posts

Joined
Wed Apr 02, 2014 4:38 pm

Post by paynechia » Tue Oct 14, 2014 10:49 am

Hi,

I have the same issue but so far it is not showing up after I added ob_start (); before session_start(); in system/library/session.php

Is this the right way to solve this issue? Will this cause any effect to the site?

Hope to hearing for some advise here.

Thanks.

Newbie

Posts

Joined
Mon Mar 24, 2014 2:49 pm

Post by johnp » Tue Oct 30, 2018 5:58 am

I have the same errors on one of my sites. I use Crawlprotect which logs hack/injection attempts. This error appears at the same time as a hack/injection attempt. I have no idea if the matters are related.

Opencart 1.5.6.5/Default Theme/VQMOD 2.6.3 lover, user and geek.
Fast Service for Opencart Installs, Fixing, Development and Upgrades plus Ecommerce, Marketing and More
https://asandwhenbusinessservices.co.uk
https://asandwhenbusinessservices.co.uk ... e-services


User avatar
Active Member

Posts

Joined
Fri Mar 25, 2011 10:25 am
Location - Surrey, UK
Who is online

Users browsing this forum: No registered users and 24 guests