Post by bLIGU » Thu Nov 17, 2011 8:42 am

Outside of main Domain the connection works well, so I sended an email to support and I'm waiting for a response...

Code: Select all

220 smtp.1and1.es (mreu4) Welcome to Nemesis ESMTP server

SeedsShop


User avatar
New member

Posts

Joined
Tue Aug 23, 2011 9:08 am

Post by GPR » Thu Nov 17, 2011 7:49 pm

Maybe a silly ? but you did not use 587,25. You did delete 25 and only use 587.
Last edited by GPR on Thu Nov 24, 2011 6:05 pm, edited 1 time in total.

GPR
Newbie

Posts

Joined
Sun Nov 13, 2011 6:52 pm

Post by bLIGU » Thu Nov 17, 2011 8:02 pm

Yes yes, maybe I don't use the correct word in English :crazy:

I tried both ports, but separatedly...

SeedsShop


User avatar
New member

Posts

Joined
Tue Aug 23, 2011 9:08 am

Post by elogpete » Fri Nov 18, 2011 7:00 pm

My problem with receiving alert emails is very similar to many that have been raised in this thread, but as usual in life, it's not exactly the same as any of them!

I've been using OpenCart 1.4.9 successfully for about nine months, but have never been able to make it send alert emails when someone places an order. But here's the strange thing - it DOES sucessfully transmit an email message when someone fills in the "Contact Us" form in the store. This makes me think I must have configured email sending correctly. Or have I? Is the mechanism for sending contact messages different in some way from the one for sending order alerts?

I have set the parameters on the Mail tab to "Mail" (not SMTP), which successfully sends contact messages. All the other fields are blank apart from port (25) and timeout (5). I have also tried various SMTP configurations, but when I apply these, even the Contact Us messages don't get through. Using "localhost" or just the domain name, I get a set of "fsockopen" errors similar to those quoted in this thread. If I enter a complete set of SMTP parameters for a known email address, I get a screen message saying the message has been sent, but it does not actually arrive. So "Mail" seems to be the only configuration that gets anything through.

I use 1&1 hosting, and I know that some people think this is problematic, but I have built several other non-shopping web sites on 1&1 using normal php mail for contact forms, and these always work fine.

Could my mail configuration be wrong, or am I missing some other basic setting that would solve the problem of not getting order alerts? Thanks!

Newbie

Posts

Joined
Sun Oct 31, 2010 7:13 pm

Post by bLIGU » Sat Nov 19, 2011 2:48 am

I'm waiting the 1&1 response support service for more than 36 hours!! I'm not happy with this... :'(

Here are the code I use from ssh console to make the tries more quicly than opencart options...

Code: Select all

<?php
require_once "Mail.php";

$from = "";
$to = "";
$subject = "";
$body = "";

$host = "";
$username = "";
$password = "";
$port = "";

$headers = array ('From' => $from,
  'To' => $to,
  'Subject' => $subject);
$smtp = Mail::factory('smtp',
  array ('host' => $host,
    'port' => $port,
    'auth' => true,
    'username' => $username,
    'password' => $password));

$mail = $smtp->send($to, $headers, $body);

if (PEAR::isError($mail)) {
  echo("<p>" . $mail->getMessage() . "</p>");
 } else {
  echo("<p>Message successfully sent!</p>");
 }
?>

SeedsShop


User avatar
New member

Posts

Joined
Tue Aug 23, 2011 9:08 am

Post by bLIGU » Sat Dec 03, 2011 2:08 am

The technical service confirm that 1and1 don't have allowed the service SMTP between our WEB Servers and Mail Servers on port 25 or 587.

SeedsShop


User avatar
New member

Posts

Joined
Tue Aug 23, 2011 9:08 am

Post by UFELLA » Tue Dec 06, 2011 8:36 pm

Sorry for jumping on this post

In a nutshell - admin not getting any emails at all all though the order confirmation is being sent to clients. But clients are not getting return emails with an RMA - Am i right in thinking that this functionality is not working

Basically I'm running OC 1.5.0.5 - I have done a fair bit of tweaking and hence don't want to upgrade - i need to get my site fully tested by the end of the year.
Hosted with uk2.net
Linux
Apache 2.2.21
PHP 5.2.17
MySQL 5.0.92

The package works like a dream elsewhere but this is frustrating the hell out of me.

Have changed the sys settings on admin side to everything I can think off - mail to smtp and then various smtp ports 25/465/587 - I'm not getting any error messages just no emails to either admin or client.

Any help much appreciated.
Best
John


Actually just sorted the admin email issue - but can anyone help with the RMA issue.
Best
JB

Newbie

Posts

Joined
Sun Nov 20, 2011 10:58 pm

Post by Pittman » Wed May 02, 2012 2:44 am

Well, after WEEKS of having my company's IT tech look into server settings, me researching countless sites, and a ton of other things we looked into....this is how I resolved it for us.

In the "Settings" area, under the "Mail" tab.....first select "SMTP", then make sure that the "SMTP Host" is set to the same thing you used when setting up the core install. For example, I used "localhost" when setting up the core install, therefore, it was necessary to put "localhost" in the "SMTP Host" area rather than "incoming.domain.com" or "mail.domain.com"

Everything works fine with my forms/email now. Try that and let us know if that works for you.

See attached screenshot.
Settings.png

Settings Screen Shot - Settings.png (128.76 KiB) Viewed 3864 times


Newbie

Posts

Joined
Fri Mar 09, 2012 12:43 am

Post by shenanigans » Fri May 18, 2012 5:52 pm

none of the above works for me unfortunately. i'm using 1&1 as well, but it doesn't work with my strato, my gmail or gmx account either. the problem is OC. it's so frustrating!!

New member

Posts

Joined
Mon Jun 14, 2010 5:22 am

Post by Pittman » Mon May 21, 2012 8:18 pm

shenanigans wrote:none of the above works for me unfortunately. i'm using 1&1 as well, but it doesn't work with my strato, my gmail or gmx account either. the problem is OC. it's so frustrating!!
Try contacting your host. I had to call Hostmonster and because we are using in-house MX servers for our email, we had to make sure that whatever email we wanted to use in Opencart had an email account setup in our cPanel, and they (Hostmoster) had to make sure the email was set to "remote" on their end (since we use in-house MX servers for our email). Once they changed that setting and we set the SMTP host to "localhost", everything works fine now.

Newbie

Posts

Joined
Fri Mar 09, 2012 12:43 am

Post by raynalyn » Sat Dec 08, 2012 9:08 am

Just wanted to echo what andy bauer posted
I used mydomain.com without www as hostnmae and it worked
BTW hostmonster is my host

thanks Andy!

Newbie

Posts

Joined
Thu Nov 08, 2012 10:44 pm

Post by Noelinar » Sat Mar 21, 2015 9:01 am

AndyBauer wrote:SOLUTION: I had my hostname wrong. It's not SMTP.1and1.com rather it's suppose to be the domain name of your shop with out the wwww. So it's myDomain.com.

Thanks
Andy!!!! YOU ARE THE SOLUTION MAN!!!! YOU DID IT!!! THANK YOU VERY MUCH!!! WORKING!!!!


Newbie

Posts

Joined
Thu Mar 05, 2015 9:10 am


Post by pogoo » Sat Jun 04, 2016 6:32 pm

AndyBauer wrote:SOLUTION: I had my hostname wrong. It's not SMTP.1and1.com rather it's suppose to be the domain name of your shop with out the wwww. So it's myDomain.com.

Thanks
I tryed to figure out how to make my email to work and i tryed everything till i fin this post :D id like to txh for your post now my email is working i can send emails and stautses updates for costumers all good and like tou sayd you need to put your host email adress without the www thx im realy happy that i can use my email :D

Newbie

Posts

Joined
Sat Jun 04, 2016 6:28 pm

Post by crazygamer » Tue Oct 17, 2017 5:19 pm

In system->settings->mail you have to specify in the hostname if you are using ssl or tsl. I use zoho and they give a hostname like this: smtp.zoho.eu . You have to use ssl://smtp.zoho.eu or tsl://smtp.zoho.eu in order for the smtp mail to work. For me this solved everything. Hope it helps ;D

Newbie

Posts

Joined
Wed Oct 04, 2017 9:05 pm
Who is online

Users browsing this forum: No registered users and 19 guests