Post by amarnz » Tue Apr 05, 2011 5:02 am

Hi

What is the function of SMTP in mail( Settings>mail)?

Can I email setup in SMTP ?

Please help.

Thanks

Newbie

Posts

Joined
Wed Mar 30, 2011 7:22 am

Post by florinsith » Tue Apr 05, 2011 5:18 am

Most of hosting companies provides support for smtp(Simple Mail Transfer Protocol). Is probably the best way to do it , if you have an email adress on your domain (ex: admin@yourdomain.com). When you first bought the domain and hosting , you probably also received your smtp setting.
If you dont have instruction , maybe this helps:

Go to yoursite.com/cpanel Trough that adress you will navigate to your domains cpanel , log in , and under the email tab , select "create new emai adress" , after you do that , using those settings , set your email in opencart backend.(is used to email customers from store)

The best program for sending and receiving emails is in my opininon Mozzila Thunderbird (this one is going to create your settings automaticaly)

All the respect!

Image
My Extensions - SuperTheme - Opencart templates - Opencart modules


User avatar
Expert Member

Posts

Joined
Fri May 14, 2010 2:36 am


Post by amarnz » Tue Apr 05, 2011 7:44 am

I have no problem with my hosting service emails, I want to send emails through my open cart, when customer send msg through CONTACT US or REGISTERED as a new customer so both is us should receive emails.

How can I setup this in open cart, I have entered my hosting service address and my SMTP details but after fill the contact us form on website I can see the confirmation msg on website screen but not receiving emails as a store owner and as a customer.

Please help about this.

Thanks

Newbie

Posts

Joined
Wed Mar 30, 2011 7:22 am

Post by amarnz » Tue Apr 05, 2011 8:41 am

Hi

I am using latest version 1.4.9.4 OPEN CART. I want to send emails through my open cart, when customer send msg through CONTACT US or REGISTERED as a new customer so both of us should receive emails.

How can I setup this in open cart, I have entered my hosting service address and my SMTP details but after fill the contact us form on website I can see the confirmation msg on website screen but not receiving emails as a store owner and as a customer.


Thanks

Newbie

Posts

Joined
Wed Mar 30, 2011 7:22 am

Post by mberlant » Tue Apr 05, 2011 7:03 pm

This question is identical to the one you posted in your other thread, http://forum.opencart.com/viewtopic.php?f=19&t=29788. Please be patient and await further conversation there.

Please use proper English at all times, so that all members may understand you.


User avatar
Active Member

Posts

Joined
Sun Mar 13, 2011 8:33 pm

Post by AndyBauer » Mon Apr 11, 2011 5:49 am

I'm having the same issue. I'm using the latest version of OpenCart. It was a clean install.

I don't receive any emails when a new customer signs-up nor do I receive emails when customers email me from the "Contact Us" form. Although, on the "Contact Us" page, after I hit "send" I am taken to a page saying that my email was sent successfully.

Below I've attached a screenshot of how my settings < mail in the admin area is set-up.

My web host is 1&1.com.

Thanks!

Attachments

delete.jpg

delete.jpg (80.53 KiB) Viewed 24376 times


Newbie

Posts

Joined
Thu Apr 07, 2011 10:36 pm

Post by florinsith » Mon Apr 11, 2011 5:53 am

Have you tried with the mail protocol SMTP?

Image
My Extensions - SuperTheme - Opencart templates - Opencart modules


User avatar
Expert Member

Posts

Joined
Fri May 14, 2010 2:36 am


Post by AndyBauer » Mon Apr 11, 2011 7:33 am

Yes, I did try with SMTP protocol but still no emails were delivered to me.

Newbie

Posts

Joined
Thu Apr 07, 2011 10:36 pm

Post by SXGuy » Mon Apr 11, 2011 6:36 pm

again another 1and1 mail issue, this keeps happening with anyone hosting with them, they really need to sort this out.

change port 25 to port 465, that may fix your issue.

Active Member

Posts

Joined
Sun Nov 08, 2009 2:07 am

Post by AndyBauer » Mon Apr 11, 2011 10:01 pm

Thanks. I just tried 465 but got a warning:
Warning: fsockopen() [function.fsockopen]: unable to connect to smtp.1and1.com:465 (Connection refused)
Now that I know it's a 1&1 issue, I'll contact them for a solution. If they resolve my issue I'll post it here.

Newbie

Posts

Joined
Thu Apr 07, 2011 10:36 pm

Post by AndyBauer » Tue Apr 12, 2011 4:41 am

I contact my webhost 1&1 and they want me to provide the scripts of the contact form so they can check to see if I need to use mrelay.perfora.net. Where can I find that script that has the values for the smtp server, the email address, and the port number? Or rather, what is the name of the file that contains the portion which asks for the mail server, the email address, and the port number?

Thanks!

Newbie

Posts

Joined
Thu Apr 07, 2011 10:36 pm

Post by AndyBauer » Tue Apr 12, 2011 10:10 pm

SOLUTION: I had my hostname wrong. It's not SMTP.1and1.com rather it's suppose to be the domain name of your shop with out the wwww. So it's myDomain.com.

Thanks

Newbie

Posts

Joined
Thu Apr 07, 2011 10:36 pm

Post by quocbinhvip » Fri Apr 22, 2011 3:58 pm

I've configured for Gmail, but not receive incoming messages, I have to configure how to receive mail from the customer?

Attachments

gmail.PNG

gmail.PNG (14.67 KiB) Viewed 24351 times


https://quocbinhvip.blogspot.com
https://sites.google.com/site/qbinh68/
https://sites.google.com/site/qbinh68/t ... t/opencart


New member

Posts

Joined
Sun Mar 20, 2011 3:58 pm

Post by ruffyleaf » Fri Apr 22, 2011 5:57 pm

Hi everyone,

Some Hosts don't allow you to mail from an external SMTP server.

You may need to configure an Email account from within your Host, then use those settings instead.

- visit us @ www.xm-i.com -


Newbie

Posts

Joined
Wed Mar 30, 2011 5:02 pm

Post by quocbinhvip » Mon May 09, 2011 9:51 pm

I was trying to make a connection to email my gmail mailbox book "OpenCart 1.4 Template Design Cookbook"guide but what I get is an error line:

Code: Select all

Warning: fsockopen() [function.fsockopen]: unable to connect to ssl://smtp.googlemail.com:465 (Connection timed out) in /home/openscor/public_html/system/library/mail.php on line 159Warning: Cannot modify header information - headers already sent by (output started at /home/openscor/public_html/index.php:92) in /home/openscor/public_html/system/engine/controller.php on line 27
let me ask how to implement it without fail.

Attachments

set Email 02.jpg

set Email 02.jpg (35.63 KiB) Viewed 24294 times


https://quocbinhvip.blogspot.com
https://sites.google.com/site/qbinh68/
https://sites.google.com/site/qbinh68/t ... t/opencart


New member

Posts

Joined
Sun Mar 20, 2011 3:58 pm

Post by amarnz » Fri May 13, 2011 4:07 am

Hi

I couldn't setup email in SMTP and my hosting service was not very good and this is my annual renew time so I have joined "ARVIXE" and everything is sorted, you can install Open cart a single click and email problem also solved and they are giving so many other features as well in best price.

thanks

Newbie

Posts

Joined
Wed Mar 30, 2011 7:22 am

Post by uksitebuilder » Sat Jun 11, 2011 3:50 am

I use 1and1 for opencart

Strange the 'Mail' setting doesnt work for opencart, it does for many other packages I use.

I have a managed dedicated server with 1and1.

For opencart 1.5.0.3 all i did to get it working was to choose 'SMTP' option and enter 'localhst' in the host, leaving the port etc as default.

ImageImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by bLIGU » Wed Nov 16, 2011 1:42 am

AndyBauer wrote:SOLUTION: I had my hostname wrong. It's not SMTP.1and1.com rather it's suppose to be the domain name of your shop with out the wwww. So it's myDomain.com.

Thanks
uksitebuilder wrote:I use 1and1 for opencart

Strange the 'Mail' setting doesnt work for opencart, it does for many other packages I use.

I have a managed dedicated server with 1and1.

For opencart 1.5.0.3 all i did to get it working was to choose 'SMTP' option and enter 'localhst' in the host, leaving the port etc as default.
Hi all,

I have the same problem than we. I have an 1and1 Linux Hosting and I receive allways this error message:
Warning: fsockopen() [function.fsockopen]: unable to connect to localhost:25 (Connection refused) in /htdocs/system/library/mail.php on line 160Error: Connection refused (111)

I try yours solutions and other forms, but the result is allways the same.

Mail Protocol: SMTP
Mail Parameters: info@mydomain.com
SMTP HOST: smtp.1and1.es/localhost (try both)
SMTP USERNAME: info@mydomain.com
SMTP PWD: user_pwd
SMTP Ports: 25/587 (try both)

Where is the problem? Any idea?

SeedsShop


User avatar
New member

Posts

Joined
Tue Aug 23, 2011 9:08 am

Post by GPR » Wed Nov 16, 2011 9:27 pm

I had the same problems where i would get a email saying a new account had been opened but no email was being sent to the new account holder.

To solve this problem I had to change the PORT number , I found what port number I had to use by contacting my mail hosting company. In my case 1stophostinguk .

I have tested this by opening a account on my site and using one of my email addreses after account was setup an email was recieved to explain my account was now open.

GPR
Newbie

Posts

Joined
Sun Nov 13, 2011 6:52 pm

Post by bLIGU » Wed Nov 16, 2011 10:48 pm

Thx for the answer but it isn't a problem with port number because when I create the account, 1and1 give me this settings:

imap.1and1.es
pop.1and1.es
smtp.1and1.es
Ports: 587, 25

And I tried boths....Any new ideas? :drunk:

SeedsShop


User avatar
New member

Posts

Joined
Tue Aug 23, 2011 9:08 am
Who is online

Users browsing this forum: No registered users and 25 guests