Page 1 of 1

OC 1.5.4 with PHP 7.2

Posted: Sun Nov 25, 2018 7:07 am
by SpannerMagnet
Hi guys, I set up OpenCart 1.5.4 for a friend a few years ago. The web host has recently informed us that PHP 5.6 is going to expire soon and that we need to move to PHP 7.2. is OpenCart 1.5.4 compatible with PHP 7.2? Is there a way of making it work?

Re: OC 1.5.4 with PHP 7.2

Posted: Sun Nov 25, 2018 8:46 am
by IP_CAM
You might find an answer to this here:
http://forum.opencart.com/viewtopic.php?f=199&t=208476

Re: OC 1.5.4 with PHP 7.2

Posted: Sun Nov 25, 2018 6:09 pm
by SpannerMagnet
Thanks for the quick response, Ernie!

So, in theory I should only need to complete the following steps?

1 - update the encryption.php file
2 - update the bcrypt.php file
3 - install "Mysqli for Opencart 1.5.x" extension

Re: OC 1.5.4 with PHP 7.2

Posted: Sun Nov 25, 2018 10:45 pm
by IP_CAM
Well, it might also depend on some extensions, but the other fellow
made it work this way. And I so far only found that file/image-editor,
unable to further do it's job, as it comes by default. But you won't be
able, to destroy anything by trying, so, just go ahed! :D
Ernie

Re: OC 1.5.4 with PHP 7.2

Posted: Mon Nov 26, 2018 7:45 pm
by SpannerMagnet
That worked a treat, Ernie. Thanks so much!