Post by bigbankclub » Sun Apr 29, 2018 7:37 pm

I have a string across the top of the page.

Code: Select all

Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in C:\xampp\htdocs\dev\opencart\system\database\mysql.php on line 6
Any idea how to get rid of this?

Newbie

Posts

Joined
Fri Dec 26, 2014 10:35 pm

Post by xxvirusxx » Sun Apr 29, 2018 7:39 pm

Edit both configs and try to change from mysql in mysqli.

Active Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm

Post by bigbankclub » Sun Apr 29, 2018 7:42 pm

Ok did that.

Now white screen with:

Code: Select all

Parse error: syntax error, unexpected 'else' (T_ELSE), expecting function (T_FUNCTION) in C:\xampp\htdocs\dev\opencart\system\database\mysqli.php on line 54

Newbie

Posts

Joined
Fri Dec 26, 2014 10:35 pm

Post by xxvirusxx » Sun Apr 29, 2018 7:47 pm

viewtopic.php?t=151859

LE. Also you should update to 2.3.0.2 if you don`t have more custom module.

Active Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm

Post by bigbankclub » Sun Apr 29, 2018 8:03 pm

Problem Solved

Now the demo site working. Ideally I should be at a NEWER version. Working with a client version, that they refuse to upgrade.

Thank you - High Fives!! ;)

Newbie

Posts

Joined
Fri Dec 26, 2014 10:35 pm

Post by EvolveWebHosting » Sun Apr 29, 2018 10:15 pm

bigbankclub wrote:
Sun Apr 29, 2018 8:03 pm
Problem Solved

Now the demo site working. Ideally I should be at a NEWER version. Working with a client version, that they refuse to upgrade.

Thank you - High Fives!! ;)
You could let them know that support for php5.x is being dropped at the end of this year and this may help to convince them to upgrade their software. php7 is also 2-3 faster and more efficient.

Image
https://www.evolvewebhost.com
Unhappy with your current host? We can migrate your account today (usually for no fee)! Visit our website and signup and we'll take care of the rest!
24/7/365 support
Image


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA

Post by IP_CAM » Mon Apr 30, 2018 1:38 am

Well, OC v.1.5.6.x works perfect up to PH 7.0.xx, just not with PHP 7.1.xx, so there
is not need tp move up in OC Versions, just because of that. Exept for the OC Install
Routine itself, it needs to be reworked, to still function with a PHP 7.0.x install.
But performance-wise, I have never experienced any increase in performance, by
changing to PHP-7, just to mention this.
Ernie

Ernie's OpenCart v.1.5.6.5 LIGHT + V-Pro + OpenShop Admin v.1.75 Test Sites
http://www.bigmax.ch - http://www.opencart.li/shop/ - http://www.velomech.ch/cart/
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by bigbankclub » Mon Apr 30, 2018 6:30 am

Yes I agree and as per upgrading, some clients are sticks in the mud. I have clients on various outdated versions of Drupal (using 6) or WordPress using 3.X.X -- so this is life..

Newbie

Posts

Joined
Fri Dec 26, 2014 10:35 pm

Post by IP_CAM » Mon Apr 30, 2018 8:39 am

Well, some drive their old Car's, as long as they do their Job well. I'm also still
in Love with my XP's, and I see not one good reason, to learn, how to handle
latest Win Versions, to just end up, basically doing exactly the same as before,
just in a completely new and strange looking surrounding, and by use of unfamiliar
new tools.

And as long as 'real' security-related problems can be fixed, and/or Layouts adapted
to meet latest User-Demands, there is no good reason, to change existing Software,
before it's beeing required by a Hoster Setup Change. New does not automatically
mean better, faster, or safer, as History proves.
Ernie

Ernie's OpenCart v.1.5.6.5 LIGHT + V-Pro + OpenShop Admin v.1.75 Test Sites
http://www.bigmax.ch - http://www.opencart.li/shop/ - http://www.velomech.ch/cart/
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland
Who is online

Users browsing this forum: No registered users and 18 guests