Post by maybeweb » Thu Mar 22, 2018 7:08 pm

Hello, it's me again :)
I recently migrated my OpenCart 1.5.4. store to www.liturgix.org/lit154 (new hosting).
Now when I tried to login to my admin panel (admin/MilkA#2016), I received the following error message :
"Not Found
The requested URL /lit154/admin/index.php was not found on this server.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

Note that the original OpenCart store (identical to the migrated one) is currently located at www.liturgix.org and the access to the admin panel works properly.
Any ideas what could be done to resolve the problem?
Your help and time are appreciated!
Milka

User avatar
Newbie

Posts

Joined
Tue Jan 22, 2013 10:10 pm
Location - Sofia, Bulgaria

Post by straightlight » Thu Mar 22, 2018 7:50 pm

Ensure your config.php and admin/config.php files as well as your .htaccess file uses the correct statement and relative server paths once the migration has been done.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by maybeweb » Thu Mar 22, 2018 11:49 pm

Hello, thank you for your prompt reply.
Actually, I thought all configuration files were written correctly, but who knows :)
The point is that I got the error message after entering the user and password, i.e. the index.php file in my admin folder loads correctly initially.
If that may help, please find attached the config.php files as well as .htaccess file (located in http://liturgix.wwwmi3-ss14.a2hosted.com/lit154):
=========================================================
# Prevent Directoy listing
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "\.(tpl|ini|log)">
Order deny,allow
Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

# RewriteBase /
# RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
# RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
# RewriteCond %{REQUEST_FILENAME} !-f
# RewriteCond %{REQUEST_FILENAME} !-d
# RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
# RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

RewriteBase /lit154/
RewriteRule sitemap.xml /index.php?route=feed/google_sitemap
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]
============================================

Any ideas what to do to resolve the problem.
Your help and time are appreciated!

Milka

User avatar
Newbie

Posts

Joined
Tue Jan 22, 2013 10:10 pm
Location - Sofia, Bulgaria
Who is online

Users browsing this forum: No registered users and 17 guests