Post by maybeweb » Thu Mar 22, 2018 2:45 am

Hello, I just migrated my OpenCart 1.5.4. store to www.liturgix.org/lit154 (new hosting).
Unfortunately, I figured out that all pages using SEO URLs don't load properly and I receive the following error message :
"Not Found
The requested URL /index.php was not found on this server.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."
I use the .htaccess file as follows (the same is used on my current hosting):
=========================================================
# Prevent Directoy listing
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "\.(tpl|ini|log)">
Order deny,allow
Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

# RewriteBase /
# RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
# RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
# RewriteCond %{REQUEST_FILENAME} !-f
# RewriteCond %{REQUEST_FILENAME} !-d
# RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
# RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

RewriteBase /
RewriteRule sitemap.xml /index.php?route=feed/google_sitemap
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]
============================================
Note that the original OpenCart store (identical files) which I am trying to migrate is currently located at www.liturgix.org and it works properly.
Also, the front page as well as the pages that doesn't use SEO URLs load properly (see: http://liturgix.wwwmi3-ss14.a2hosted.co ... on/contact)

For example, following pages experience the issue:
http://liturgix.wwwmi3-ss14.a2hosted.com/lit154/payment [the footer menu, the first column]
http://liturgix.wwwmi3-ss14.a2hosted.co ... 4/delivery [the footer menu, the first column]
as well as the products and categories pages:
http://liturgix.wwwmi3-ss14.a2hosted.co ... nts/priest [the category in the product's menu]
http://liturgix.wwwmi3-ss14.a2hosted.com/lit154/n0039 [a product's page]

Please, advise what to do to resolve the problem.
Your help and time are appreciated!

Attachments

notfound01.jpg

notfound01.jpg (82.04 KiB) Viewed 391 times

notfound02.jpg

notfound02.jpg (76.82 KiB) Viewed 391 times


User avatar
Newbie

Posts

Joined
Tue Jan 22, 2013 10:10 pm
Location - Sofia, Bulgaria

Post by IP_CAM » Thu Mar 22, 2018 3:45 am

Well, if your shop is located here:
http:// www. liturgix. org /index.php?route=common/home
OC .HTACCESS Setting looks like this:

Code: Select all

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/
# RewriteBase /
But if your Shop is placed like this:
http:// www. liturgix. org /lit154/index.php?route=common/home
OC .HTACCESS Setting looks like this:

Code: Select all

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/
# RewriteBase /lit154/
Ernie
---

For Sale: Top URL's, including an OpenCart V-Pro Installation, similar to:
http://www.bigmax.ch - http://www.ipcam.li - http://www.jti.li
For Information + URL's offered, please contact me at: jti@jacob.ch
I am NOT available for Custom Support in existing OC Installations!
My Github Repositories: https://github.com/IP-CAM
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by maybeweb » Thu Mar 22, 2018 6:54 pm

Thanks a lot for your prompt reply and help! All is fine now. ;D
Milka

User avatar
Newbie

Posts

Joined
Tue Jan 22, 2013 10:10 pm
Location - Sofia, Bulgaria
Who is online

Users browsing this forum: No registered users and 20 guests