Post by mighty9403 » Mon Mar 13, 2017 5:49 pm

Is there a comprehensive guide to upgrading to the new version of opencart. I would like to have a go at it and would like some advice about the best way to go about it . I'm guessing that the data base has changed and some modules will not work. I'm going to try it on a testing server. Many thanks in advance.

New member

Posts

Joined
Tue Aug 28, 2012 4:28 pm

Post by IP_CAM » Wed Mar 15, 2017 4:33 am

Just, if you want to make sure, that it will work again.
Or then, for Non-Coders, one has a good Chance, to just ruin a working Shop.
And this will cost much more, on time, frustration, and money.
Then, you can work again. Hopefully, because, if you used Custom Extensions
before, or VqMod's, or even a Theme, mostly nothing of it will be usable anymore.
Good Luck, Ernie
---
1. Server Side:
--------------------
a. Create a First new empty DB, serving as DB Copy, to later be used as v.1.5.x SOURCE.
b. Copy/Paste the existing Shop DB Content into the new created DB Copy. (by use of the MyAdmin MySQL-Tool)
c. Create a Second new empty DB, to be used as V-2 Installation DB.
---
2. Server Root / Software:
----------------------------
a. Create a new Shop Subdirectory.
b. Upload the New V-2 Shop into this Directory.
c. Install the new V-2 Shop on the new DB, created for the V-2 Shop Installation.
d. Get Qphoria, PM-Netti, or someone else, capable to, to rework/copy/paste
the Content of your saved Copy of the 1.5 DB onto to new V-2 DB.
---
Then, if it works, you may remove the old Installation and DB, and rewrite the
both config.php und .htaccess file|s, after renaming the Subdirectory on the Server
again, to match the known Shop URL.

Ernie's OpenCart v.1.5.6.5 LIGHT + OpenShop Admin v.1.75 Test Sites
http://www.ebikes.li - http://www.evelo.li - http://www.openshop.li
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by litextension » Fri Mar 17, 2017 5:35 pm

You can find the detailed solution and support via topics on OpenCart 2.0 Support in OpenCart Forum. I see many people have demand to upgrade OpenCart 1.5 o 2.

You can consider given information:
Backup your database.
Log in to OpenCart Administrator panel.
Uninstall all modules that activated.
Uninstall extension which are not originally.
Log in to your phpmyadmin panel.
Go to your database and import the migration sript.
Download and extract opencart zip to your opencart directory.
Update download and image directory.
Configuration config.php and admin/config.php files.
Log in to administrator panel again and setting up the user groups permission.
Update the store settings and categories.

User avatar
Newbie

Posts

Joined
Wed Aug 03, 2016 4:22 pm
Who is online

Users browsing this forum: No registered users and 62 guests