Post by chrisgwynne » Sun Nov 27, 2016 4:44 pm

Hi guys

Woke up this morning not being able to access my admin. Login would not allow. Edited something and now I have a 500 error on admin.

[Sun Nov 27 08:26:58.521365 2016] [cgi:error] [pid 11194] [client 86.161.65.106:51914] AH01215: PHP Fatal error: Call to a member function isLogged() on null in /home/xxxxx/public_html/vqmod/vqcache/vq2-catalog_model_catalog_product.php on line 468: /usr/local/cpanel/cgi-sys/ea-php56

Tried deleting entire contents of vqcache. Didn't work. Checked config files for public and admin both seem to be correct.

HELP!

New member

Posts

Joined
Fri Nov 11, 2016 7:33 am

Post by chrisgwynne » Sun Nov 27, 2016 11:13 pm

Ok really need help. Tried everything I can think of all day to fix this issue.

Public Config

Code: Select all

// HTTP
define('HTTP_SERVER', 'http://www.xxx.com/');
define('HTTP_IMAGE', 'http://www.xxx.com/image/');

// HTTPS
define('HTTPS_SERVER', 'https://www.xxx.com/');
define('HTTPS_IMAGE', 'https://www.xxx.com/image/');
Admin Config

Code: Select all

// HTTP
define('HTTP_SERVER', 'https://www.xxx.com/admin/');
define('HTTP_CATALOG', 'https://www.xxx.com/');
define('HTTP_IMAGE', 'https://www.xxx.com/image/');

// HTTPS
define('HTTPS_SERVER', 'https://www.xxx.com/admin/');
define('HTTPS_IMAGE', 'https://www.xxx.com/image/');
Admin Error 500, check the log and I get

Code: Select all

[27-Nov-2016 14:54:20 UTC] PHP Fatal error:  Call to a member function isLogged() on null in /home/xxx/public_html/vqmod/vqcache/vq2-catalog_model_catalog_product.php on line 468
I've tried clearing vqcache, I've tried rerunning vqmod/install/ - file says index.php is not writeable, even tho it 100% is on 755 or 777, tried both!

Front end works fine. Please help! :(

New member

Posts

Joined
Fri Nov 11, 2016 7:33 am

Post by thekrotek » Mon Nov 28, 2016 3:04 am

It has nothing to do with permissions or any other stuff you did. A function isLogged() is called in vq2-catalog_model_catalog_product.php file on line 468 and it doesn't exist of required model is not loaded. Just open the file and see the whole line - you'll get more understanding of the issue.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Active Member

Posts

Joined
Sun Jul 03, 2016 12:24 am

Who is online

Users browsing this forum: No registered users and 17 guests